PDA

View Full Version : requirements for Maya plug-in programming


pursuit
10-17-2006, 10:00 AM
hi everyone,
i want to start to write simple plug-ins instead of mel scripts for maya, i read the maya's help page, however i am not clear about my requirements. I am a newly graduated comp eng and i have a programming background however i dealt with mostly java and unfortunately not the comp graphics. I have some C knowledge and for Maya plug-ins I will use C++.
On help page of Maya it says i need MS Visual Studio.NET 2003, however i have 2005 version, in addition i wonder whether or not i need an extra C++ compiler. i have never used MS .NET and i want to know what i have to do to be able to start plug-ins without any problem, that is, what settings should i perform(environment variables etc.),what should i set-up, compilers, editorss, any toolkits???
I will be very grateful for any help, thanks a lot...

kjaft
10-17-2006, 11:33 AM
hi there,
basically you just need the compiler/IDE and a Maya installation with devKit. It's recommended to use VS .Net 2003, but there shoud be no problem using 2005/XPress. There are some useful threads regarding this topic in the highend3d.com Maya API forum (e.g here (http://www.highend3d.com/boards/index.php?showtopic=215588)).
Another sollution, can be found here (http://forums.cgsociety.org/showthread.php?t=227419&highlight=2003+toolkit), the only problem is that the mentioned VC 2003 Toolkit afaik is no longer available at the MS website. I heard some that its now included in the .Net SDK, but I didn't check that out.

If you use .Net you would like to Install the Maya project wizard, which automatically creates a basic code/file structure for you. After this you should be ready to compile maya plug-ins without.

Check out some other resources:
http://www.robthebloke.org/
www.ewertb.com (http://www.ewertb.com/) (offline, use internet-archive.org)
http://www.comet-cartoons.com/3ddocs/mayaAPI/

have fun!
felix

CGTalk Moderation
10-17-2006, 11:33 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.