View Full Version : GI Disco Ball of Doom

10-02-2006, 05:27 PM
I'm trying to render some scenes using Global Illumination, but I keep getting this horrible speckled effect (that looks like a disco ball is being used to illuminate the room). I have tried several different things to fix it, bit with limited results. I was hoping someone could give me some advice…

I am using a single light source, with the intensity turned to zero, but I have it set to emit photons. The light source is illuminating an enclosed room that has a large glass table in the center and some models of furniture and whatnot around it.

Rendering time is no issue, because I am only doing a single frame and want it to look as nice as possible. I don't care if I have to leave the computer rendering all night (or even into the next day, since I'll be at work). With that in mind I have been setting the Global Illumination and Caustic accuracy to MAX (1024 for GI and 100 for Caustics, I think). Every slider that seemed related to GI or caustics I ALSO turned up (all those photon depth sliders and whatnot from the Photon Volume controls, right below the GI controls, although I have no idea if this is even doing anything).

I got my photon intensity and exponent looking good using only 50,000 photons. But this left the render all splotchy. So I cranked up the photons to 100,000 and got a better result (but it was still splotchy). At 150,000 things looked even better. But at 200,000 photons I started getting these hot spots where it looked like too many photons were colliding in one spot. Since the manual says turning up the photons will always increase the quality, I figured what the hell? So I tried first 1,000,000 photons, then 2 mil and finally 5 mil, but I kept getting the hotspots (they might have even become brighter with more photons). Above 5 million I started getting "out of memory" errors, so I couldn't push it any further.

Having maxed out the photon options I switched to adjusting the "Radius" values in the render options. At low values (<1) it made the render look ten times splotchier. So I thought higher values would fix it. I tried several, and at around 10 radius the splotchiness was reduced, but still visible. Anything higher than that didn't seem like it was doing anything.

So I tried cranking up the photons, the accuracy and even adjusting the radius factor, but I was unable to fix the horrible disco ball effect. I thought turning on final gather might be the solution, but it causes weird artifacts (even with the accuracy maxed) if you try to use it when the GI is already producing the disco ball effect.

So… Any suggestions?

10-09-2006, 10:27 PM
Two things come to mind...

1) you aren't approaching the gi tweaks properly... There's no way you should need that many photons... you can get results with 15000 photons... FInd some GI tutorials if you haven't done so yet. Once you get the overall lighting where you want it, you start tweaking the accuracy and radius to remove the splotchiness...

2) check the scale of your scene... is it very very large? Lighting is scale dependent... DOn't go too small or too large... Try to fit your scene within reasonable clips.

10-10-2006, 12:39 AM
Dude, if you've changed way too many parameters and you don't know what they all are, then start over with a clean slate. Just select your objects and maybe a light, and export selected as a new file. Then start with a new scene and just import the geometry. Life will get better.

You can usually just leave the radius at 0, and the size will auto-adapt to the number of photons, so they get smaller when there are more of them. Put some kind of an environment, like a sphere, around the whole scene so the photons can bounce back and don't get lost in space. If you use a directional light you'll need to fix it so the sphere doesn't cast shadows so it doesn't block all the light, but directional lights are nice in terms of not needing such mega-huge photon intensities like point and spot lights do.



CGTalk Moderation
10-10-2006, 12:39 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.