PDA

View Full Version : DVD Performance Still REALLY Bad


Northchild
02-01-2003, 05:51 PM
I've been fighting this for a while now. I'm running Windows XP Home and have purchased the WinDVD4 software codec. This problem happens whether I'm playing DVDs in Windows Media Player OR the WinDVD player. Hardware is an ASUS board, Athlon 2100, ti4600, 1 gig of RAM.

The DVD video seems to be good, but the audio stutters just enough to screw up a good experience and my hard drive chugs constantly.

Does anyone have any experience with this? I have no idea where to go from here. :( I would yell at the WinDVD people, but I don't think that it's WinDVD's fault.

Thanks again,

jscott
02-01-2003, 06:48 PM
Is the DVD your playing on a disk or are you playing if off your hard drive.

Whenever I feel my HD is working hard when maybe it shouldn't I run a scan disk on it and then defrag that sucker.

It does seem kind of wierd. My system is only a P3 1ghz w/GeForce4 4400 and I have viewed a few DVD disks with no problems.

Hey is your avatar pic from a 3ds max tutorial? That brings back memories. later.

-jscott

Northchild
02-01-2003, 07:43 PM
Nah, I keep my drives well-defragmented. It's not that. The video SHOULD be playing off of the DVD. I have no idea why the hard drive is working at all.

Yep, that's a 3ds max tutorial, it's really basic, I know. ;)

EvilE
02-01-2003, 09:29 PM
To things come to my mind :
1. Are you shure you have DMA turned on for your DVD Rom ?
2. What chipset has your board and what audio card are you using ( i experienced lots of problems with via chipset and audigy card a while ago )?

EE

Northchild
02-01-2003, 11:10 PM
What's DMA?

The Asus board is an A7M266 with AMD761 chipset. I'm using the onboard audio.

singularity2006
02-14-2003, 04:11 AM
check your DMA (data transfer protocol for IDE channels) by going through your hardware manager, disk controllers > primary IDE, secondary IDE and select "enable UDMA" or "DMA."

elvis
02-14-2003, 05:39 AM
from memory DMA modes are set by default in windowsXP.

i can only offer general advice here: make sure you are running the latest video and chipset drivers from the chip manufacturers themselves (not the board manufacturers if possible), and double check your background tasks to make sure nothing is taking up too much CPU time. even so, I used to happily play DVDs through a dedicated PC back in my uni days that was a celeron300 overclocked to 450MHz. a multi-gigahertz machine shouldn't break a sweat.

one more thing to check: make sure your swap file is a hard-set size with minimum and maximum sizes set equal to stop swapfile resizing. by default the windows swap file shrinks and grows as it sees fit, which means a lot of disk IO which will bring any machine to it's knees regardless of how great the CPU is.

Northchild
02-14-2003, 11:42 AM
Many thanks, will try altering the swap file properties. :)

CGTalk Moderation
01-14-2006, 07:00 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.