PDA

View Full Version : RiggingPRO Question


kennez
09-30-2006, 10:06 PM
I just purchased the RiggingPRO video from 3DQuakers, and although I haven't watched it all yet, I have a question about the 'skin bones' that are used.

Are these used purely for the video to demonstrate the rig, or do they help somehow when it comes to enveloping/weighting?

If they are a normal part of this particular rig, what is the method for enveloping and weighting using this system? Is it similar to the method used when just enveloping a normal skeleton?

Sorry for the (probably) stupid questions, but I am new to XSI, and rigging, although I do use Messiah occasionally.

Sbowling
10-01-2006, 12:18 AM
The skin bones are what you envelope to. The "real" bones don't actually get enveloped to anyhting. This setup comes in real handy if you have to make some modifications to the rig after it's been enveloped. Also, since these are polygon objects, you can edit them so they really match the size and shape of your character mesh and you can just use that when animating, which can be quite a bit faster than showing the character mesh.

Womball
10-01-2006, 05:21 AM
Skin bones? And also how to do you exactly envelop the skin bones? And how do you go about weightpainting?

tredeger
10-02-2006, 12:34 AM
Skin bones? And also how to do you exactly envelop the skin bones? And how do you go about weightpainting?


XSI let's you envelop to any object and you do it just the same way as you would if you were enveloping to bones. XSI rocks.

madheavy
02-03-2007, 12:45 PM
I got the RiggingPro DVD and I'm having one problem that I thought I could get past, but I cannot. It is on the leg 'mirroring' section. When I try to parent my skin bones, they jump all over the place, and I don't know why.

To get around this I decided that after I duplicated my skin bones, I would parent them at the same location without moving them. It seemed to work and I was able to complete the 'mirroring' section. Yeah....However, after saving the file and re-opening it, I found that my skin bones had moved and that some of the items I ALT + A to (match all transforms) were all messed up.

I don't know what to do. I'm using XSI 6.0.
http://i15.photobucket.com/albums/a359/madheavy/SkinBonesMoving.jpg%5D%5BIMG%5Dhttp://i15.photobucket.com/albums/a359/madheavy/th_SkinBonesMoving.jpg%5B/IMG%5D%5B/URL%5Dhttp://i15.photobucket.com/albums/a359/madheavy/SkinBonesMoving.jpg
Thanks,
http://i15.photobucket.com/albums/a359/madheavy/SkinBonesMoving.jpg%5D%5BIMG%5Dhttp://i15.photobucket.com/albums/a359/madheavy/th_SkinBonesMoving.jpg

3DQUAKERS
02-03-2007, 03:36 PM
Anthony,

I took a look at the file.
The problem came from the fact that you set a keyframe on the null called knee_point, which was creating the offset when mirroring.
So I deleted that and mirrored the rest and it worked just fine.

Remember not to set keyframes on objects you need to mirror staticly, otherwise you would get unpredictable results.

madheavy
02-04-2007, 09:59 AM
Thank you very much!! It worked! I must have pressed 'k' by accident somehow. I'll be more careful. Funny I deleted all of the keyframes that I made, but it still didn't work correctly until I deleted that knee point null. Thanks!!

CGTalk Moderation
02-04-2007, 09:59 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.