PDA

View Full Version : XSI: Biped Rig Anomoly


MonkeyLord
09-20-2006, 04:01 AM
I'm having a bit of a problem with the biped guide and creating a rig from the guide.

1. I've shaped the guide as needed to fit the character model. However, when I generate the rig, the right foot, starting with bone RFootBone1 is complete wrong. Here's a screenshot showing the problem:

http://www.badgeofblood.com/monkeylord/wackyrig.jpg

The right foot (the one on our left) is positioned entirely incorrectly. I can recreate the problem easily... every time I've loaded the guide and moved the ankles into proper positions, the right foot comes our mangled when I generate the rig.

So, what I need to know is:
1. What am I doing to cause this? Or is this a known bug?
2. Or, failing that, how do I move the bone into the proper position?

I don't have a lot of experience with character rigging in XSI, and I can't seem to find out how to move the bone into its proper position at the end of the shin bone. Every attempt I've made to apply a transform has failed.

Thanks!

PS: Also of interest: In everything I've read, I SHOULD be able to delete items from the biped guide, like fingers, correct? Well, everytime I've tried to do so, the script that generates the rig will invariable freeze about 1/4th of the way through the cycle, with the progress bar indicating that it was trying to generate the hands. :| I don't need ANY fingers for this model, but attempts to remove them from the guide and successfully generate the rig have failed.

Oh, and I'm using XSI 5.1

CGTalk Moderation
09-20-2006, 04:01 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.