PDA

View Full Version : Maya 4.5 Orient Joint error


Doogie
01-24-2003, 02:11 AM
I'm trying to use the Orient Joint tool in Maya 4.5. I keep getting this error.

// Warning: Skipping b7: It has non-zero rotations. //

all the joint's rotations are at 0 and it doesn't look like anything in influencing the roataions. Docs don't seem to say anything. Same w/ searching elsewhere.

QuantumPixel
01-30-2003, 07:52 AM
are you using the jsOrientJointUI in maya

Doogie
01-31-2003, 05:00 PM
Whatever that new tool in Maya is (not a script/plugin)

sp0rk3d
02-07-2003, 05:15 PM
I am not sure if this is the problem you are haveing but make sure you are NOT in gimbal rotation mode while orienting joints... it won't work.... local rotation mode works best ... i assume you have the joints selected in ogject mode then switched to component mode and are using the "?" filter in component mode to select the local rotation axis..... :) hope this helps

seasterling
02-08-2003, 12:06 AM
I'm getting these errors in 4.5 a lot as well, with any script that wants a joints rotations to be zero. Haven't found a common denominator yet.

boygonemad:
Why do you ask? I'm interested because I've noticed some funkiness in Maya's rotations after running the script. I posted a thread a day or two ago in the Maya forum called jsOrientJoint wierdness. jsOrientJoint wierdness (http://www.cgtalk.com/showthread.php?s=&threadid=42130)

CGTalk Moderation
01-14-2006, 07:00 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.