PDA

View Full Version : Shadow in FG rendering


diginime
08-04-2006, 05:14 PM
Hi guys, i have a question about shadow here. I had search around the forum but it seems like didn't have any answer my question.

Ok, i create a scene and i deleted the default light. Then i create a point light and change the colors to about .005, then i check on enable shadow. Then i created a cube and apply a constant material to it. Value to 1.But when render, it didn't show up any shadow. can anyone solve this for me? Thanks.

FG configuration:
Sampling
Accuracy = 500
Min/Max radius = 0 ( I don't know what is this because i'm learning FG right now :))
Bounces = 0
Pre-Sampling Density = 1
Filter Size = 1

By the way, in the render option, i enable the raytraced shadow, type is regular. Shadow map i check the two boxes.

elfdestruct
08-04-2006, 10:36 PM
First, the constant shader doesn't work with direct illumination/scene lights how other shaders do. Say you have a grid with a phong shader under a cube with a constant. You'll see shadows cast on the grid but nothing happening with your cube. Place another cube with a phong shader next to the other cube & you'll understand even more clearly. :) Oddly enough, that cube (with the constant shader) will react to indirect illumination, such as FG, in a standard sort of way.

As to your point light, position it well, it's much more dependent on location/proximity to scene objects than, say, an infinite light. Also, a color of .005 sounds quite quite low, unless you have the intensity way way overdriven. I'd suggest starting higher & going lower with your color as you refine your scene. You may also want to try lowering the Umbra in the light's shadow settings, the lower you set it the darker shadows will be.

For FG, the Min/Max defines the sampling area for illumination. The numbers translate to scene units by default, with View Dependent on it refers to pixels. You should start high & go lower with those settings normally. For accuracy, try the opposite, going low to high as you refine.

diginime
08-05-2006, 02:57 AM
I used the constant cube with white color as the light source (It's renderable, but i didn't render in the scene). I use the point light is only for its photon effect. Can you simplifiy it?

:) Oddly enough, that cube (with the constant shader) will react to indirect illumination, such as FG, in a standard sort of way.
How to do it? What does it means? I start a new scene file and created a constant cube and normal grid. Then I turn on the Final Gathering and render the constant shader cube, but it seems like the same.

elfdestruct
08-05-2006, 04:04 AM
I must have misread. Sure, I can simplify.

Try this plugin: http://forums.cgsociety.org/showthread.php?t=345713

It basically turns objects into area lights.

Here's a video tutorial on it's use: http://splin.c3dmotion.com/shaders/index.php?action=list&dir=XSI%2FCtrl_Studio%2FHOWTO&order=name&srt=yes

hobo
08-05-2006, 08:18 AM
Here's a video tutorial on it's use: http://splin.c3dmotion.com/shaders/index.php?action=list&dir=XSI%2FCtrl_Studio%2FHOWTO&order=name&srt=yes

any idea what codec is needed?

edit:

found it, needs the techsmith screen capture codec.

CGTalk Moderation
08-05-2006, 08:18 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.