PDA

View Full Version : Particles not updating at rendertime


blakboks
07-24-2006, 05:38 PM
Hello,
I'm having an issue lately--not sure what's causing it--where my particles simulate fine in the viewport, but at rendertime, it only renders the 1st frame in the sequence correctly, and the particles don't move for the rest of the sequence. It renders the whole sequence, but the particles aren't being updated at render time. Anyone have any ideas what might be causing this? I tried doing a quick search in this forum, but with no luck. I've also tried applying a cache operator with Use At: Set to Viewport/Render, but this did not solve the problem, either.
I appreciate any help anyone can offer.
-Chris

OlegB
07-24-2006, 06:12 PM
Chris,

It's all scene specific - send you file to Orbaz support please - I'll check it out.

Thanks,
Oleg B.

blakboks
07-24-2006, 07:05 PM
Ahhhh, I've found the problem. Unfortunately, I have no idea how to fix it (at the moment). It turns out that it is because I am using the Render node->Render Result: as Mesh Per Particle. It works properly if you use Single Mesh. You can test this out on your own with a simple scene. However, then I run into some serious memory problems at render time, causing it to crash, since I'm trying to instance geometry (only 406 faces) 20,000+ times in Mental Ray. So, now, does anyone know how I might be able to overcome the memory problems?

OlegB
07-24-2006, 07:20 PM
Some renderers do not support Mesh Per Particle option. Besides single mesh, you have another alternative in the Render operator where you specify how many particles should be set per mesh.

In you case you can set "30 meshes" with "1000 particles per mesh".

Thanks,
Oleg B.

blakboks
07-24-2006, 11:04 PM
First of all, thanks for your help, Oleg.
I'm trying that and it's still not able to render. The closest I came was with 10000 meshes with only 1 particle per mesh (which is only half of the particles then if I'm trying to do 20000 particles, correct)?

I've tried using placeholders. I've tried Grid and Large BSP acceleration. I've tried collapsing the instance geometry to editable mesh. None of which have worked. I find it difficult to believe that I'm pushing the limits of the program and my system at only 20000 particles with only 420 faces per particle. Every time it fails even on the first tile. I haven't tried chucking the monitor out the window yet--I'll try that if I can't get anything else to work. Again, anything anyone has to offer would be welcomed and much appreciated. Thoughts, anyone?

Thanks,
Chris

OlegB
07-25-2006, 12:00 AM
Chris,

You need to use "Multiple Meshes" option with Mesh Count = 30 and Particles p/Mesh = 1000

Note from the docs about "Mesh Per Particle" option - "...this is the least efficient method of operation, but might be required by certain renderers". Which means - use it as a last resort :)

Thanks,
Oleg B.

blakboks
07-25-2006, 04:19 PM
Yes, I tried using 30 / 1000 and that didn't work either. Were you able to get it to work with the scene I sent you? I'm 'only' running 2GB of RAM here--maybe I need to see about getting some more.

I think I've heard about a level of detail script somewhere (or maybe a Box#3 operator)--this might help me out, but I'm not making any guarantees--anyone know where I might be able to find it, or provide some tips on how to construct such a thing?

Thanks,
Chris

OlegB
07-25-2006, 05:21 PM
I haven't looked at the file yet, sorry. The level of details idea may work. You need to create a Distance test operator (with Box#3 or Script) that calculates the distance from particles to the camera. In the scene you would need several events with different shape details, and the Distance test redirects particles from one event to another.

Thanks,
Oleg B.

blakboks
07-25-2006, 06:18 PM
Thanks for the tip for the level of detail Oleg. I'll have to try that at some other time. I finally got the particles to render. I used the good 'ol PFTools freebie Camera Cull. So, thanks very much for a.) making that operator to begin with and b.) making it free! As always, much apprection, Oleg.

-Chris

CGTalk Moderation
07-25-2006, 06:18 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.