PDA

View Full Version : Xdof mental ray wont batch...


OrganisedChaos
06-16-2006, 03:36 AM
ok so it says xdof for maya supports the new versions of mental ray,
but i hit single frame render and it has a whinge for the first few times then renders the frame after a while.
batch render will not render at all...
this would be fine if i wanted to render every single frame in render view, but i dont.
the error it gives is:
API 0.0 error 301030: C:/Program Files/Alias/Maya7.0/mentalray/include/xdof.mi, line 3: mi file requires ray version 3.3.99 or older, this is 3.4.5.2
how can it not render in 3.4.5.2 if it says its compatible with it...is this just mine or do other people get this?
and if its not compatible, why is it after it cancels the first 2 renders will it render the third one onwards without a problem?
anyone got any ideas?

grafix
06-16-2006, 09:54 AM
Hi Chaos,

often it helps editing the .mi file: open xdof.mi in a txt editor, go to line 3 and change the "3.3.99" into a "3.4.99"

No guarantee that it works but generally it does...

OrganisedChaos
06-20-2006, 01:11 PM
Hi Chaos,

often it helps editing the .mi file: open xdof.mi in a txt editor, go to line 3 and change the "3.3.99" into a "3.4.99"

No guarantee that it works but generally it does...

well it sorta worked...and sorta didnt...
it rendered one frame, to 100%, then it paused for a good 5 minutes and then said rendering completed.
the rendered file was empty (the standard 128 bytes) and the renderlog had this to say:

Error: (Mayatomr) : unexpected internal exception during scene rendering, please report

i think i should just find an old version of mental ray and it might work with that.
stupid bloody thing. and it obviously works with the newer versions as ive had completed rendered frames from it!

thanks anyway.

CGTalk Moderation
06-20-2006, 01:11 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.