PDA

View Full Version : splining question


ZenTarzan
06-11-2006, 04:18 AM
im splining out some animation. when i spline some keys, the whole curve will jump down a couple units in the animation editor, so then for example my head intersects with hands and such. my girlfriend is having the same problem when she switches from spline to linear interpolation. is there a reason for this? or is this just a really big bug? any work arounds? Please help:sad: thanks guys.

Sbowling
06-11-2006, 04:53 AM
My guess is that you are having the normal problems that pop up when converting from linear to spline curves. What is happening is that when the linear curves area converted to spline curves, the interpolation causes the curves to round off at the animation keys and in some places the curves will now actually pass above the keyed values, before or after hitting the actual keyed values.

I recommend opening the curve editor for the object having the problem and watching what happens to the curves when converting them from linear to spline. The best way to solve this problem is to select the key and hit Shift 0 to flatten out the handles for the curve.

Edit: put the F in shift.

ZenTarzan
06-11-2006, 04:59 AM
im not sure what you described is my problem... when i interpolate the keys... the keys themselves are moved. is that what you meant? im not sure i understand your zeroing out technique if it is.

Sbowling
06-11-2006, 05:25 AM
im not sure what you described is my problem... when i interpolate the keys... the keys themselves are moved. is that what you meant? im not sure i understand your zeroing out technique if it is.

So you mean that if you set a key at X1,y2,z3 and then convert your curves from linear to spline, the key values are changed? I just did a test and everything works as expected here.

How exactly are you converting the curves from linear to spline? Maybe I'm not correctly understanding the problem.

ZenTarzan
06-11-2006, 06:33 AM
thats exactly what i mean. heres a picture... sorry its so big, but i wanted to make sure you could see it. the first is linear (i keyed it all in constant, but when i changed it to linear nothing moved). the second is splined.. all i did was select the keys and hit the little spline button (blue arrow). You can see how much the keys jumped when set to spline... is that normal or something stupid im doing?

http://i2.photobucket.com/albums/y26/ZenTarzan/cgpostsplines.jpg

Sbowling
06-11-2006, 07:43 AM
OK, It's very close to what I thought it was. If you look at the little black handles on the (red) keyframes, they are causing the odd motion. The keys are in the correct place, but the handles are causing the interpolated curves to go below or above the key values. You can manually drag the handles around to adjust they angle or length, or you could select a whole group of them and adjust the slope length and angle numerically. If you set the handle length to 0, you will essentially have linear keyframes again.

If you look at the lowest keys on the left of the screen you can see that the handles are essentially pointing up and down. Try dragging the handles around the keyframe so they are pointing the opposite way and see what happens. Also, select them and hit Shift 0 and see what happens. These are very handy for adjusting things like ease in and ease out and are also very important in fixing foot slip and other such problems. I believe this stuff is covered in the Character animation Tutorials that come with XSI, but I'm not completely sure. I highly recommend reading through them.

ZenTarzan
06-11-2006, 04:55 PM
i dont really understand why that worked... but it worked, which makes you my hero. thanks so much. do you think you could try to explain whats going on there, for educational sake? i see why the curve would have made the objects overlap, but why did the keys move, or appear to move, or whatever happened?

Jesse-Irvin
06-11-2006, 07:08 PM
How did that work? I mean seriously... looking at that chart I really don't get how that was a splining problem. I mean those keys actually move... the keys that are around 0 jump up to .1.... I don't get it...

tuna
06-11-2006, 08:10 PM
I've never seen this happen either (looks like a +0.11 value change). Does it only happen in this scene?

Another way of trying this is if you only select the curves (DESELECT all the keys, so they aren't red) then do curves > spline interpolation. Do the keys all still get value changes when you do it this way?

ZenTarzan
06-12-2006, 03:31 AM
i dont understand it at all. tuna... to answer your question, sometimes... mostly it has the same effect. but not every curve would jump like that... whatever happened Mr. Bowling's fix worked (for the most part, there was a couple that still jumped, so i just left them with linear interpolation). i guess im no splining expert... so whatever. thanks again for your fix sam!

CGTalk Moderation
06-12-2006, 03:31 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.