PDA

View Full Version : Anim Editor: There are no nodes to show in this View


RenderFX
06-01-2006, 04:14 PM
Hey guys, how u doing?? A few days ago, a friend of mine told he had xsi V. 5 or something. The thing is iīve heard so much about itīs animation capabilities, that as a max user, honeslty impressed me. So, he opened the application, and I instantly took the mouse away from him and quickly animated a cylinder translating in X direction, it was cool smooth and fast. Then I started looking after the curve editor, that I found after a while under the name of Animation Editor. With the animated object selected, I opened it and.... There are no nodes to show in this View !! Donīt matter what I do the key points wonīt show up nor the curves in the Animation editor... :'(

I hope someone could help me with it, I donīt know what is going on but itīs frustrating, and my friend donīt let me use his workstation too long...


thnx in advance

mocaw
06-01-2006, 05:52 PM
When you say nodes do you mean a flow of nodes like the rendertree or do you mean curv points?

RenderFX
06-01-2006, 05:56 PM
I guess I mean curv points.....

dwigfor
06-01-2006, 06:41 PM
You should be able to select your object and hit 0 to bring up Anim Editor. If that doesn't work, select the object, ctrl k to bring up the local kinematics ppg. right click on the animated parameter (pos x for example) and pick Animation Editor.

inneractive
06-01-2006, 06:50 PM
Hitting "F" will also "Frame" the curves for the selected object and you can zoom in on the keys you want. The is a standard, vertical, and horizontal zoom.

RenderFX
06-01-2006, 06:57 PM
You should be able to select your object and hit 0 to bring up Anim Editor. If that doesn't work, select the object, ctrl k to bring up the local kinematics ppg. right click on the animated parameter (pos x for example) and pick Animation Editor.

thnx, that worked well :), but, the object node still doesnt appear at the left window, someone knows why the objects animated parameters doesnt appear when I select an object?? (it doesnt even appear in the anim editor as selected) and yes, iīve tried with almost all the view options within the anim editor, weird...

tuna
06-02-2006, 05:43 AM
thnx, that worked well :), but, the object node still doesnt appear at the left window, someone knows why the objects animated parameters doesnt appear when I select an object?? (it doesnt even appear in the anim editor as selected) and yes, iīve tried with almost all the view options within the anim editor, weird...

In your animation editor, click on the "view" menu, and you'll have a bunch of ways of filtering the channels (nodes to view on the left). It sounds like they're all being filtered right now by something. Checking things like "animated perameters only" or "selected perameters only" might help. Then checking "all nodes" or "local transform" should show the keys you've set.

[edit]
Actually the problem sounds like the editor is just locked. You see the button with a padlock icon? Make sure that's unchecked, or hit the recycle icon button next to it to sync selection.

RenderFX
06-02-2006, 03:06 PM
In your animation editor, click on the "view" menu, and you'll have a bunch of ways of filtering the channels (nodes to view on the left). It sounds like they're all being filtered right now by something. Checking things like "animated perameters only" or "selected perameters only" might help. Then checking "all nodes" or "local transform" should show the keys you've set.

[edit]
Actually the problem sounds like the editor is just locked. You see the button with a padlock icon? Make sure that's unchecked, or hit the recycle icon button next to it to sync selection.

THAANKS!! I just started clicking everywhere in the editor, "all nodes" "general properties", but what i think what unlocked the editor was when I clicked on "position----> all", or at least I think so :) ...

thanks dudes, you rock guys!!:buttrock:

CGTalk Moderation
06-02-2006, 03:06 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.