PDA

View Full Version : lightwave obj. import to xsi


ponni
05-21-2006, 12:02 PM
hi
i'm new to xsi and i've built and textured a model in lightwave 8.0 .Now i want to animate it, but not in lightwave, i wanna do it in xsi ( i find character animation in it, miles behind the rest of the 3d packages esp. xsi in setup and features). i'm using xsi foundation 4.2. The imported model comes in fine but none of the uv come in, the tick boxes in the import options are checked but no uv's can be found, what i'm doing wrong or will i have to retexture it in xsi ( i hope not cause i'm still trying to find my way around the render tree in xsi.). please help!

yog
05-21-2006, 03:23 PM
hi
i'm new to xsi and i've built and textured a model in lightwave 8.0 .Now i want to animate it, but not in lightwave, i wanna do it in xsi ( i find character animation in it, miles behind the rest of the 3d packages esp. xsi in setup and features). i'm using xsi foundation 4.2. The imported model comes in fine but none of the uv come in, the tick boxes in the import options are checked but no uv's can be found, what i'm doing wrong or will i have to retexture it in xsi ( i hope not cause i'm still trying to find my way around the render tree in xsi.). please help!What Export/Import format are you using.
OBJ works very well, but LW has a peculiarity in that it wont export UV's with an OBJ unless a texture map is attached to the UV data in LW.

Also, as a person who has used LW for many years, I would recommend learning to UV map in XSI, it's FAR better ;)

dickma
05-22-2006, 07:41 AM
There's a exporter from www.ef9.com (http://www.ef9.com)

LemonNado
05-22-2006, 11:24 AM
Point Oven does not transport texture either....
You have some work ahead of you!
Rainer

ponni
05-22-2006, 05:50 PM
Thanks for the all advice and exporter plugin i'll try that later, but to the first reply i know, ireally should get into the render tree uv texture editor of xsi.

ThE_JacO
05-23-2006, 12:04 AM
the render tree is not the same of the texture editor, and obj normally should carry across UVs and can support one basic material that is saved in an external file (provider the exporter will).
The problem you have though is probably down to LW providing one of the worst obj I/O in history, but have you tryied what Yog was telling you?

ponni
05-27-2006, 10:06 AM
thanks for the relpys, great help.
i used the lightwave to xsi exporter and after a bit of searching in xsi (i'm new to it) i found where xsi keeps the the uv's. i also found that xsi put a default surface on top of the lightwave suface so i deleted that and then added the uv's which were perfect and bingo textured model. the obj exported model did work but the uv's where screwed up from lightwave.

mocaw
05-27-2006, 04:32 PM
What Yog said should work. I've been using this method and all has worked find for me. What type of UVs are you using from LW? only linear will transfer as far as I know.

CGTalk Moderation
05-27-2006, 04:32 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.