PDA

View Full Version : maintenance for 5.1?


themick_g
05-17-2006, 10:27 AM
Hi,
I got a problem to download xsi 5.1.
We have bought XSI 5.0 Essentials without maintenance contract.
Do I need to have a maintenance to get the update? The page doesnt acept my customer ID?!
thx
mick

ThE_JacO
05-17-2006, 10:39 AM
www.softimage.com
support@softimage.com
sales@softimage.com