PDA

View Full Version : Blendshape Difficulty


2creative
05-10-2006, 08:46 AM
Iím having a little trouble with animating with blendshapes. My character model (created in Maya 6.5), is moving and speaking at the same time. The movement part is coming fine but as far as the blendshapes go, there is some problem.


When I set keys to the blendshape nodes and try to play it in the scene, then what happens is that, the character moves but the lip sync or blendshape doesnít show (even though Iíve keyed it in earlier). However, if I scrub through the timeline or move through the animation frame by frame, the lip sync occurs and the blendshape node changes are visible. So they are probably being recorded...yet they're not visible in the scene!?

So I canít understand the reason why this is happening. :shrug:

Also, does anyone know how can I remove all the keys for all the blendshape nodes, if I wanna start afresh with them? Tried ĎReset Allí on the blendshape editor, but didnít work.

So basically, the problems Iím facing are-

1) The changes I make to the blendshape nodes do not show in the scene, but are visible by moving the slider on the timeline, frame by frame.

2) I cannot reset the values of the blendshape nodes i.e, remove all keys that have been set so that I can start keying blendshapes afresh.

Please Help!:sad:

Thanks in advance.

puresugar
05-18-2006, 10:25 AM
Could be lots of things.

try setting your Playback Speed to 'play every frame' in your Preferences (under Timeline), it sounds like your scene doesn't update quick enough to calculate the blendshapes

To delete all your animation curves select your Blendshape Node - in the Grapheditor delete all keyframes
or select the blendshape, in the ChannelBox select all attributes and go RightMouseclick - 'break connections'
or select the blendshapenode and go edit/delete by type/channels

I am sure there are a thousend and one more ways of doing that.

Also, if you have questions about Maya, try it in the Maya Forum. You might get a faster response.

CGTalk Moderation
05-18-2006, 10:25 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.