PDA

View Full Version : Rays Of light Entirng a room with GI


bunnyld
05-05-2006, 09:22 AM
Hey all
I set a Simple room and a window
I set on the GI: in the render options,in the light source and on the objects.

I put the point light inside the room and the GI did work fine

after that I wanted the rays come from outside of the window, so I put the light source out side where the window is

on the final render no GI radiation aplly on the room, the room got the first rays of the light and the window shape, but no PHOTONS lighted the room some reason

I olso try to use a spot light but again the GI had no affect inside the room

how can i fix this?

thanks

neogeo51
05-05-2006, 09:37 AM
Adjust the cone angle, radius of the spotlight to low value like 1o. Sometimes it might help to place a sphere with inverted normals around your scene. make sure the room objects are set as gi transmitter and receiver. Hope that helps.

bunnyld
05-05-2006, 03:49 PM
I'v done as you said
still the room is photonless

Btw I own V.4.0

Studev
05-05-2006, 05:32 PM
Strange indeed. Try set ur light exponent to 1 and see if it has any changes. If it does, set back to 2, you need to adjust ur photon intensity. I have no idea, how far ur light is from the window, try to get close. You can cheat it by placing 2 spot lights, one with photon cast nearer to window, and the other one without photon and further away from the window. However, please do remember, u need a container so that the photon have a room to bounce. Otherwise, it will be a waste.

tarkovsky
05-05-2006, 06:09 PM
If you have glass in the window, try hiding it see what happens. If your windows is double faced, the light might be bouncing between the faces or something...

kierrato
05-05-2006, 08:05 PM
Blast photon irradiance in your light to 100000, check if you see photons ... They vanish with distance. Im pretty sure thats whats your problem is.

If it doesnt work, look at your log window and check if MR is missing photons (should be something like "No photons rendered out of 300000, skipping")
If it is, it means the surface is receiving no photons.


In your render settings, the more accurate your photon calculation is, the smaller the photon will be, try tweaking that too.

MJV
05-05-2006, 08:31 PM
Delete the window, move the light into the room, test. If it works, start moving the light outside the room and further away, test, repeat.

sciics
05-06-2006, 05:29 PM
increase photon intensity of the outside light..

CGTalk Moderation
05-06-2006, 05:29 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.