PDA

View Full Version : Spring Operator Not Working in V5.1?


NeptuneImaging
05-01-2006, 01:51 AM
Hey, I am trying to apply a spring operator to simulate a pair of moving breasts (using implicit objects) and for some reason I keep on getting a ('ERROR : Object required: 'in_objects(...)' - [line 4906 in C:\Softimage\XSI_5.1_Foundation\Application\DSScripts\operators.vbs])

When I wrote the syntax in 4.2 "ApplySpringOp", the operator applied to the implicits just fine. Now I keep on getting this error. I am on the last day of my eval period of 5.1, so anyone's help will be appreciated.

Kashif R.

NeptuneImaging
05-01-2006, 12:12 PM
Okay, I read the SDK Guide and found this:
ApplyOp (PresetObj, [ConnectionSet], [ConnectType], [ImmediateMode], [OutputObjs], [ConstructionMode])
And so far I have: ApplyOp(SpringOp, *want to include my already selected objects(implicit spheres parented to each other)*, sibranch(the objects are parented to each other),siPersistentOperation,
Outputobjs (don't know what this does), siconstructionmodeanimation(want to use it on a rig))



But just have no idea how to enter it in to run it, or even if my syntax is correct. (I am not a scripter so anyone with scripting input will be
helpful

NeptuneImaging
05-01-2006, 01:45 PM
OKay, I think I have it so far: ApplyOp("SpringOp", "Biped_Rig.LeftBreastSpring;B:Biped_Rig.LeftBreastSpringHandle", siUnspecified, siPersistentOperation);

The two objects I want to have this action are parented to the chest bone, and I branch selected the second object. The script works, but the first object moves. Is there a way to counter act that?

NeptuneImaging
05-02-2006, 04:05 PM
Okay, I made a mistake. Instead of Branch Selecting, I toggled it for the second object :eek:

CGTalk Moderation
05-02-2006, 04:05 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.