PDA

View Full Version : Bump Map Rendering Issues in Mental Ray


fahr
04-25-2006, 02:10 AM
I've gone through several projects now with this same problem and cant troubleshoot my way out of it. Whenever I render a bump map through mental ray (normal maya blinn shaders, Maya 7.01), the bump map appears heavily pixelated. Rendering this same scene through Maya software produces the correct, smoothed result. The bump maps themselves are quite high resolution, and render fine in other renderers. They are TIFs (uncommpressed). Is this a common problem in mental ray, or am I just doing something wrong?
Thanks!

royterr
04-25-2006, 03:50 AM
yes you are right, the bump node from maya native shaders behave in unpredictable ways when rendering in MR.

Use a MR shader and assign the bump

fahr
04-25-2006, 04:15 AM
You mean that in order to get a good bump map I have to use a MR shader? Or just some kind of MR utility node for bump maps assigned to my Maya blinn shader?

Im sorry, but Im new to MR in general, having spent years suffering through Maya software. MR is great, but I know very very little about how to make all-MR-shaders in hypershade. Its scary and its confusing, but im ready to learn. ;)

Thanks!

MSB
04-25-2006, 10:53 AM
it had happend to me sometime ago.

I just sat the file texture filter to mipmap (the only supported one by mr) and it worked fine (don't set the filter to off) and try to increase the bump filter size abit , or try to use softer filter (that if you are using Lanzcos)

and one more thing,

mr hates tifs just change everything to tga or better map

CGTalk Moderation
04-25-2006, 10:53 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.