PDA

View Full Version : Simple character facial rig help. Workflow issues


FUoSS
04-24-2006, 08:15 PM
Hello, and thanks for taking the time to view this post and hopefully offer some feedback. I am currently working on an animated character that is a tire with eyes and arms. He will only have to perform basic animated motions like blinking and moving his mouth during speech. My main question involves workflow as far as lowpoly to subd, and handling blendshapes for facial animation.

I started with a lowpoly model outlining the main features of the character
http://fuoss.com/media/cgtalk/toby1.jpg

Next, I converted to subD and began creasing edges and making minor adjustments. As you can see, the mesh began to get quite hefty at this point. I also added some more detail like the rims and bolts.
http://fuoss.com/media/cgtalk/toby2.jpg

Next I modeled and rigged cartoon style eyeballs using Nurbs surfaces, and parented to the base mesh.
http://fuoss.com/media/cgtalk/toby3.jpg

Everything was going smoothly so far. I am finishing up the arms and hands right now (no screenshots yet). I am going to rig the arms and hands using TSM2, a rigging plugin. My concern is setting up blendshapes for the face. My question involves where to go from here to make this manageable from an animator's perspective.

My initial idea was to use the original low poly mesh to create my blendshape deformers, and then attach these to the polyproxy that is built into the subD. This did not seem to work.

Next I tried converting the subD to polys (which I will eventually need to do for rendering reasons). The mesh was very dense and hard to work with. I wanted to make more broad changes easily.

My next idea was to just duplicate the subD surface itself and create the blendshapes using the zero level hierarchy (equivalent to the base poly mesh). This works out okay, but seems a bit bulky and causes my viewport to slowdown a bit during rotations and stuff. Also, when I try to slide the bars on the shapes, the subD doesn't update very fast (even at level1 display).

I guess my main question just involves workflow, and how you go about animating dense subD meshes. In the past I have used all polys and I would just animate the base poly proxy and have a hidden smoothed version that I would unhide when it was time to render. This helped to prevent waiting for a dense mesh to update in the viewport.

UPDATE: After asking around in some other places, I was aimed in the direction of converting my subD to a poly mesh, and using the sculpt polygons tool to help with making more broad changes. This was helpful and seems to be working out ok so far. I'd still love any other ideas or feedback.

CGTalk Moderation
04-24-2006, 08:15 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.