PDA

View Full Version : Problem rendering shadows.


Alfons
04-24-2006, 05:08 PM
The darkest part of the shadow doesn't show up in the render(left on top of the lid, right side of cup). I have no idea of what's wrong. I use MR and raytraced shadows. I just used the useBackround shader and one directional light. Same result if I use the shadow pass render layer.

This is what it looks like:
http://forums.cgsociety.org/attachment.php?attachmentid=94268&stc=1

Need serious help!
Alfons


(http://forums.cgsociety.org/attachment.php?attachmentid=94268&stc=1)

yassein
04-24-2006, 11:13 PM
cast shadow from anther light
may be point light `ll ok
http://img283.imageshack.us/img283/937/render0cw.jpg

royter
04-25-2006, 04:52 AM
DON'T use the usebackground shader with MR.

Try to find a MR shader that only recieves shadows (catcher)

ajsfuxor
04-25-2006, 08:20 AM
I've never had a problem with the useBackground shader and MR.

I suggest trying to find out what is the problem first. It could be a problem with your mesh maybe? Try rendering a full render (not split into layers) with normal lambert shaders assigned to see if the shadows cast are still wrong. I'd also try a different light as well.

Also check your normals to see if they are all facing the right way.

Alfons
04-25-2006, 05:18 PM
I played around a bit more now but I can't figure it out. The normals are OK, all faceing out. I used area, point and directional lights and the same result.

I will now try to make a mr material that only recieves shadows.

Alfons
04-25-2006, 05:43 PM
ajsfuxor: I followed your advice with the lambert, but with the same end result. I attached a new picture highligthing the problem areas. I tried different colors on the shadow.

It's like Maya ignores the areas because they should be 100% Black. There seems to be a problem with the selfshadowing.

Alfons
04-25-2006, 06:08 PM
I'll try a different approch with a lambert pass instead of a shadow pass.

ajsfuxor
04-26-2006, 01:05 AM
I'd be happy to take a look at the file if u want, however, im using maya 6.5

If u want you can send me a 6.5 compatable version (or just export all the mesh as obj) at ajsfuxor@hotmail.com and ill see if i can figure it out. The problem might also be with Maya 7, in that case, i can't help.

Aikiman
04-26-2006, 04:05 AM
Maybe convert your light to a mentalray area light by scrolling down to the mr options on the light itself. Increase the samples there for a softer shadow leaving the raytracing shadow samples at default, see how you go.

Kako
04-26-2006, 05:59 AM
Are you sure there should be a shadow in that area? In my opinion the shadows are correct. The area that you outlined should be darker in the final render, for sure. However, not because of a cast shadow, but because of the absence of light. With the useBackground Shader or in a shadow pass using render layers, you will get only the cast shadows. You won't get a dark region only because there's absence of light. Otherwise, these dark areas that you think you should be getting would be multiplied by the dark areas of the absence of light of the Diffuse pass.

What do you guys think?!

Cheers,
Kako.

Kako
04-26-2006, 06:06 AM
I don't know if you'll understand what I meant. So, just to be sure, imagine that the viewport shot in the picture you posted above is a Diffuse pass. Composited with the Shadow pass, you'll get all the dark areas that you want: the cast shadows and also the "absence of light" dark areas (the ones that you highlighted in the viewport).

;)

jeremybirn
04-26-2006, 06:53 AM
That looks like a correct shadowpass.

Like Kako said, the unlit side isn't shadowed and doesn't need to be.

-jeremy

Aikiman
04-26-2006, 09:33 PM
why dont you composite it together and see if it works?

CGTalk Moderation
04-26-2006, 09:33 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.