PDA

View Full Version : Photogrammetric Projection Shader Issues


0utlander
04-13-2006, 07:10 AM
Hey im in need of some help with the projection shader available at www.thereisnoluck.com (http://www.thereisnoluck.com)

ive set up everything exactly like the tutorial here states: http://www.thereisnoluck.com/downloads/projectionShader/Using%20the%20Photogrammetry%20Projection%20Shader.pdf

however its not working.

im keeping it simple so i can get the shader working b4 applying it to a real sort of situation. At the moment I have a sphere and 2 cameras in my scene. each of the cameras has a projection of an image with a alpha channel etc as requested in the tutorial. everything works fine in the tute up to the point of rendering. when i render the scene with the projection shader assigned to the sphere i get a blank image. switching the alpha chanel on in the renderer shows that the scene is being rendered but the projection shader isnt doing its thing. no image is showing up. somtimes i dont even get this occasionally it has issues and i just get a mentalray aborted error.

the following errors appear in the mental ray log:

// Info: (Mayatomr.Nodes) : place2dTexture1.vertexUvOne: unsupported type of connection, current plug value used instead

// Info: (Mayatomr.Nodes) : place2dTexture1.vertexUvTwo: unsupported type of connection, current plug value used instead

// Info: (Mayatomr.Nodes) : place2dTexture1.vertexUvThree: unsupported type of connection, current plug value used instead

// Info: (Mayatomr.Nodes) : cameraShape1.message: unsupported type of connection, current plug value used instead

// Info: (Mayatomr.Nodes) : cameraShape1.message: unsupported type of connection, current plug value used instead

// Info: (Mayatomr.Nodes) : place2dTexture2.vertexUvOne: unsupported type of connection, current plug value used instead

// Info: (Mayatomr.Nodes) : place2dTexture2.vertexUvTwo: unsupported type of connection, current plug value used instead

// Info: (Mayatomr.Nodes) : place2dTexture2.vertexUvThree: unsupported type of connection, current plug value used instead

// Info: (Mayatomr.Nodes) : cameraShape2.message: unsupported type of connection, current plug value used instead

// Info: (Mayatomr.Nodes) : cameraShape2.message: unsupported type of connection, current plug value used instead

// Info: (Mayatomr.Nodes) : cameraShape1.worldMatrix[0]: unsupported type of connection, current plug value used instead

// Info: (Mayatomr.Nodes) : cameraShape2.worldMatrix[0]: unsupported type of connection, current plug value used instead



can ne one help me?

djx
04-13-2006, 12:21 PM
I recently encountered a problem with using maya's projection node in a mentalray render (maya7.01). I cant get it to work in "perspective" mode, where it is linked to a camera.

Someone suggested I look at Jeremy Pronk's projection shader - the one you are asking about. I have only read the docs so far but was interested to read
...this shader does not do any perspective texture projections itself. That process is currently left up to the MAYA projection texture node.

Could it be that this is the part that is failing in mentalray-for-maya7 ? Thats what my tests are telling me, but maybe you could verify that theory. In my tests the projected texture is ignoring the camera link, so it is not aligned correctly at all.

0utlander
04-13-2006, 11:53 PM
hey so it turns out i tried it again on another computer and it worked. So the original pc i was trying this out on seems to have had the plugin not installed properly or somthing... gonna have to do some tests to figure out what is goin wrong.

CGTalk Moderation
04-13-2006, 11:53 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.