PDA

View Full Version : Some Alpha Chanel Problem


katsoft
04-10-2006, 04:58 PM
Hello I am preaty new to MAx. I am makeing a cube that I applyed a texture and animate it. Anyway the bitmap I used was suposed to have a transparency ...I saved the picture as a TIF with tranparency. When I imported it in the material editor ...where the picture was suposed to be transparent I get that ambient grey and also this is how it is rendered. In perspectiv view I don't get that grey it looks like it's transparent but I realy think it has something to do with the ambient color. Can anyone help me ?

pax
04-10-2006, 10:49 PM
If I understand, you want to use the alpha channel embedded in your *.tif image to mask a portion of it.
Here is what you need to do:

1. Double check that your *.tif file has actually an alpha channel. The area you want to mask needs to be black, the rest white.
You probably already created it yourself, with Photoshop for instance.

2. In the material editor, chose a new standard material, click the "Diffuse Color" button and select your file.

3. Copy this file from the "Diffuse Color" button to the "Opacity" button (don't instance it).

4. Left click the "Opacity" button with the name of your file on it.
In the "Bitmap parameters", "Mono channel output" section, check the option "Alpha" instead of "RGB intensity".

Your material should look Ok now.

katsoft
04-11-2006, 10:28 AM
Hey...thank you very much for the info ...it worked the transparency is there in the rendered product just that the colored stuff got some transparency also ...this didn't hapen before ..is tehre any way around this ?



Thank you again very very much.

Catalin.

pax
04-11-2006, 03:57 PM
If your material is transparent at places where it shouldn't be, it's probably because the quality of your alpha channel mask is not good enough. You can fix it (in Photoshop for example), by re-editing precisely the contours/removing black spots in your b&w image stored in the alpha channel.

katsoft
04-11-2006, 05:40 PM
Yes..well the mask was ok I just changed something in the material editor and I got the result I wanted. The only problem I have now it's the lighting ....I want the material to have the same lighting as the actual bitmap on all the sides of the cube...I kinda got that effect by adding omi light on all sides but the material doesn't have that mate color that the bitmap has in the rednderd product ...is there any way to do this without me adding extra light into the scene ?...or even if I do to have the exacte same mate color ?

Thank you very much for takeing your time with a beginer like me .

Catalin.

pax
04-11-2006, 06:21 PM
If you want your material to have the bitmap "glow" by itself uniformly,

Make an instance of your "Diffuse" material in the "self-illumination" button.
Make sure the amount of self illumination is 100%.

You can get rid of the omni lights.

katsoft
04-11-2006, 06:28 PM
YES..it works exactly as I want it...thank you again very very very much for your help.

Catalin.

CGTalk Moderation
04-11-2006, 06:28 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.