PDA

View Full Version : misss_fast_skin - how to layer texture on top


mindsample
04-05-2006, 10:56 AM
I ran into a problem which I seem not able to solve.
I set up my render with the misss_fast_skin shader and am quite happy with the results. Now I would like to add a second layer to the render, i.e. a dry-skin-dandruffy look ON TOP of the skin. My attempts to use a layered shader (to mix i.e. a lambert on top of the sss) were futile as maya crashes once you mix maya layered shaders with mental ray materials (anybody else with the same problems?). The way I did it seemed a bit made up anyway, I connected the miss with the layered shader and then connected the lmaps with the shading group of the layered shader ...

Any suggestions on how to approach this task, I literally would like to add a diffuse layer with a transparency map on top of the sss shader. Maybe there is a trick to achieve this within the sss material ?

Thanks!

ghostlake114
04-05-2006, 11:48 AM
Try mix8layer man, not maya layer shader ... remember plug your miss_fast_skin_lm to your mix8layer shading engine light map shader

AndrewRaZ
04-06-2006, 12:44 AM
i usually layer the mix8 to include all specific effects i need. for instance, the base will actually be a grey blinn with a wireframe to show off the base model, and then the first skin shader is above that, and renders over it without specuarity. above that i have a separate skin shader with color and scatter off, which renders only specular bump attributes. then i have any other effects i may need above that, which may include a non-organic effect such as a hard shell on one model and reflections associated with that. this way i can turn off specific layers as needed, and if i need to go to ctrl_buffers i can pass the individual shaders to separate framebuffers.

*however* you should consider whether the the effect is worth the extra manhours and render time. yes, the dry skin/dander is something we notice on a subconsious level, but the truth is most people aren't going to notice it unless the face is plastered up on a theater-sized screen on a still image.

mindsample
04-07-2006, 10:59 AM
Thanks.


as soon as I add the mix8layer to my maya.rayrc file my mtor aborts before rendering. This happens on any scene even without using the mix8layer. I am using maya6.5 and assume it has something to do with the version of mix8layer, which apparently is written for mental ray1.1, is there any newer version available, anybody got experience that it works with maya6.5 onwards?

mindsample
04-07-2006, 11:49 AM
running on linux btw ...

-----
registry "{MAYABASE}" value "/usr/aw/maya6.5/mentalray" end registry

registry "{SYSTEM}" value "linux" end registry
registry "{DSO}" value "so" end registry

$lookup "{MAYABASE}"
$lookup "{SYSTEM}"
$lookup "{DSO}"

registry "{MRMAYA_START}"
link "{MAYABASE}/lib/base.{DSO}"
link "{MAYABASE}/lib/physics.{DSO}"
link "{MAYABASE}/lib/mayabase.{DSO}"
link "{MAYABASE}/lib/contour.{DSO}"
link "{MAYABASE}/lib/subsurface.{DSO}"
link "{MAYABASE}/lib/mi_openexr.{DSO}"
link "{MAYABASE}/lib/mix8layer.{DSO}"
mi "{MAYABASE}/include/mayabase.mi"
mi "{MAYABASE}/include/base.mi"
mi "{MAYABASE}/include/physics.mi"
mi "{MAYABASE}/include/contour.mi"
mi "{MAYABASE}/include/subsurface.mi"
mi "{MAYABASE}/include/mix8layer.mi"


echo "mental ray for Maya - startup done"
end registry

$lookup "{MRMAYA_START}"

mindsample
04-07-2006, 12:24 PM
also tried mix20, same problem. Is there really no compatible version available for maya6.5 or maya 7?

mindsample
04-09-2006, 04:04 PM
Try mix8layer man, not maya layer shader ... remember plug your miss_fast_skin_lm to your mix8layer shading engine light map shader

this is really bugging me, mix8layer (or mix20layer), do they work with maya6.5 or 7? When I add the shader to my maya.rayrc it locks up my maya-to-mental ray and aborts any render before it can be translated. This also happens when I am not even using the shader in my scene, it basically just messes up my maya.rayrc ...

has anybody used mix8layer in 6.5 or 7? Why does my one not work?

AndrewRaZ
04-09-2006, 05:35 PM
i'm using mix8 with maya 7, and once i got the maya.rayrc file corrected, it worked fine. i had a similar problem initially though.

the mix8 entries in mine are:

link "{MAYABASE}/lib/mix8layer.{DSO}"
and
mi "{MAYABASE}/include/mix8layer.mi"

which is exactly what you have, so i don't know what's going on. i think i had a problem with the latest release of mix8 though too and had to revert to an earlier one.

don't know how much of a help that will be.

mindsample
04-10-2006, 12:24 AM
thanks for your reply, could you send me a link or email me your version of mix8, the one that is workin on maya7, just to be sure? I

mindsample
07-28-2006, 03:41 PM
hey, long time no see.

I got mix20layer working in maya7, now I am trying to layer TWO misss_fast_skin shaders on top of each other. Here is how I have done it:

- lmap connected to mix20layer SG
- mentalrayTexture1 (the actual lmap image file) connected to lmap
- mentalrayTexture1 connected to both misss_fast_skin_materials

Basically the same setup when only using one sss material, but this time the actual texture is connected twice, providing the same lightmap to both materials. I believe this is the right way to do is as I obviously cant create two simultaneous lmap branches for the mix20layer SG.

Unfortunately I do not seem to get sub surface scattering to work, everything renders without errors and the mix20layer works fine, but the actual render looks suspiciously like a sss material WITHOUT a lmap attached to it.

Am I doing something wrong? Is it even possible to layer to fast_miss materials above each other using mix20layer?

CGTalk Moderation
07-28-2006, 03:41 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.