PDA

View Full Version : arm IK problem


Emah
04-05-2006, 07:04 AM
Hi, got a problem if u guyz can help me... When i add a POLE VECTOR to the IK on my Arm ... the arm twist slight back...(palm up) and the Sphere i use for the Pole Vector moves down. Just wondering wuts up with this..and is it gonna cause me any problems if I keep it like this to animate...Also another question..is there a way to change my current Leg IK from IKSCsolver to IKRPsolver w/o killing the whole Leg rig i built... the problem..i can't add Pole Vector to the current IKSCsolver on my leg.

redcarrot
04-05-2006, 06:30 PM
Hi
Select ur ik handles and Ctrl-A which brings up attribute editor, u could change ur SC solver to RP solver from the IK Solver attributes. If u r using SC solver, there is no necessary to add a pole vector, just rotate the knee with ur ik handles.

For ur arm problem, it might be the arm joints are not properly line up, freeze ur rotation axis of all joints and try to make it in a straight line from the front view.

good luck

Emah
04-07-2006, 08:14 AM
thanx buddy...one more thing... there a problem w/ animating the IK for the arm and not making controllers for it?....just wondering

PEN
04-07-2006, 01:10 PM
You should always make controls for you rig and not just allow animators to grab IK handles. This cleans up the rig for one and makes it obviouse as to what you should be animating. It also alows for further layering of control to the system as well.

CGTalk Moderation
04-07-2006, 01:10 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.