PDA

View Full Version : 'stepped' zbrush bump map in maya


crexnfx
04-04-2006, 07:51 AM
hi all,

i posted this in the maya forum, thanks to tciny for responding
and i was hoping someone here might be able to help

have a problem here, i made a bump map in zbrush and applied it to a model in maya.
when i render in maya, the bumps (warts) are pretty pixelated, but even worse
the rest of the model which has no bump, is not smooth...instead it's all 'stepped'


this is what i did:
-made a model in maya, and smoothed once (so it should all be quads)
-applied automatic mapping
-exported model as obj from maya
-imported model into zbrush
-divided geometry 4 times
-hit projection master, and started painting bumps and wrinkles

-after painting bumps, i lowered the geometry divisions back to 1
-under the 'displacement' section, i did not click 'Mode' and slid DPRes to 4096
-then clicked 'create dispmap'
-under 'alpha' tab i flipped the image in V, then exported as a tif file

-opened the tif file in photoshop and converted to RGB (it is 16 bit)
-in maya applied the image as bump map, and rendered...
-i played around with the render settings, but no difference, the 'steps' are still there
-i adjusted the bump levels also, but that only makes the warts less noticable
but the 'steps' are still there.


anyone have any ideas?
hope you guys can help

DaedraLord
04-04-2006, 12:07 PM
go under properties in your computer, and see what happens when you set your color to 16 bit. the blending colors are very rigid, very much like your bump map. try opening it up and saving it as a 32 bit bitmap

crexnfx
04-04-2006, 06:45 PM
thanks for responding Daedra Lord,

when you say check properties in my computer...

do you mean check in Control Panel > Display Properties > Settings?

when i check, the Color Quality is already set at 'Highest(32 bit)'


or do you mean in Photoshop, saving the bump map as 32 bit?

because i don't see that option under Image > Mode

only 8 bit or 16 bit.

krolichka
04-04-2006, 07:22 PM
how did you do your bumpmap in zbrush? did you use the bumpwiever material? if not pick that material to see if your bumps look okey in zbrush. Back in maya you could lower your filter to lets say 0.1 in the bump map, the artifacts use to disappear if you lower that value.

krolichka

DaedraLord
04-04-2006, 10:47 PM
thanks for responding Daedra Lord,

when you say check properties in my computer...

do you mean check in Control Panel > Display Properties > Settings?

when i check, the Color Quality is already set at 'Highest(32 bit)'


or do you mean in Photoshop, saving the bump map as 32 bit?

because i don't see that option under Image > Mode

only 8 bit or 16 bit.
let me try and reword that:


example: if you set your color mode to 16 bit, it gets all strange the same way your bump map is, most people have it in 32, if you know how 16 bit color effects the computer leave it as 32 bit.

to solve this problem with your bump map: in photo shop save your bump map as 32 bit color, or export it in zbrush as 32 bit color. that way it will be smooth.

you saved the bumpmap as 16 bit color.
if you dont have a back up than your going to have to do some
editing in photoshop to restore the same smooth quality and the finer details.

crexnfx
04-04-2006, 11:40 PM
thanks again for responding Daedra Lord and to you too krolichka,


krolichka>

initially i didn't use the bumpviewer material, only the default 'Fastshader' when
i imported, and it displayed the bumps nicely when i painted them with
Projection Master.
i also tried using the bumpviewer material, when painting in ZB
but there is no difference, because when i export the bump map to maya
the steps are still there.

i have played around with the filter in maya, lowering the settings
does make the steps less noticable, but it also flattens the bumps too.
so that doesn't really help.


Daedra Lord>

fortunately, i haven't done any major painting yet, only a lot of testing.

i use photoshop CS, and there is no option to make the tiff 32 bit,
only 8 or 16, is there a plugin i need?

the same goes for exporting a tiff in ZB, i don't see the options to change
it to 32 bit...again is it a plugin?


btw, i've hit 'Init Zbrush', so i'm guessing that makes all settings to default.
is there any options or settings that i should be aware of to export
bump maps.


i really hope you guys can help, cuz i'm going crazy doing A LOT of back and forth testing.
thanks in advance

DaedraLord
04-05-2006, 04:13 AM
whats the resolution (size) of your map?
and are you saving it as bmp or tiff? try saving it in a format that will do least damage to the quality of your map. (as far as i know a 32 bit bmp would be the best option.)

crexnfx
04-05-2006, 08:01 AM
hi again,

i've exported various resolutions in ZB, from 1024 to 4096 but it doesn't seem to make a
diifference, they still step the bump map.

i've tried, converting the alpha to a texture in ZB, then exporting...but still the
same 'stepping'

i've tried applying just the exported 8 bit bump map from ZB
and also converting it to 16 bit in photoshop but both are the same when
applied in maya.

CGTalk Moderation
04-05-2006, 08:01 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.