PDA

View Full Version : HD for hardwareplayer.


DarkstaR1st
03-29-2006, 09:32 PM
Hey guys,

Help me out here... I've been searching the web for some good info for a week now.

I've made some motiongraphics at a resolution 1920x1080. I need to get that rendered to a MPEG with a maximum bitrate of 38MB/s for a hardware HD streamer that plays it at HDTV 1080i.

The player also plays WMV. But with everything at the highest setting it still looks rubbish. I think it still compresses way to much even at the highest setting. (but not sure). I've added a screen of my settings for WMV.

http://www.dennist.nl/WMVsettings.gif

I need the best quality there is (of course :))

Anyone have some good tips for me or places to search for my answers.

Thanx a lot,

Dennis

beenyweenies
03-30-2006, 01:52 AM
Hey guys,
I've made some motiongraphics at a resolution 1920x1080. I need to get that rendered to a MPEG with a maximum bitrate of 38MB/s for a hardware HD streamer that plays it at HDTV 1080i.
But with everything at the highest setting it still looks rubbish.

Dennis

My personal experience is that getting a good WMV9 file without a hardware (i.e. expensive) device doing the compression is rare.

But at the same time, quality is subjective. What you call rubbish may just be the interlacing or something else solvable. Can you post a frame, perhaps?

DarkstaR1st
03-30-2006, 05:43 AM
Ok here's a 5 sec clip from that movie...

http://www.dennist.nl/Comp 1_7.zip

The player streams at 40MB/s. With this file i'm at a tenth of the max bitrate.

Oh yeah, the video that plays on the tv is footage i had to rip from a DVD... I think i have a interlacing problem there and definitely a FPS problem. How can i make a 25fps run at 29.97fps without the jitter?

But first, the quality of the whole frame

Thanks
Dennis

beenyweenies
03-30-2006, 07:30 AM
Ok here's a 5 sec clip from that movie...

http://www.dennist.nl/Comp 1_7.zip (http://www.dennist.nl/Comp%201_7.zip)

The player streams at 40MB/s. With this file i'm at a tenth of the max bitrate.

Oh yeah, the video that plays on the tv is footage i had to rip from a DVD... I think i have a interlacing problem there and definitely a FPS problem. How can i make a 25fps run at 29.97fps without the jitter?

But first, the quality of the whole frame

Thanks
Dennis

Ok it looks pretty decent to me, but I'm assuming you're referring to the banding on your background. Subtle gradients like that will band when compressed, and there isn't much you can do after the fact except use better compression. I could be wrong but I think you might need a fairly pricey hardware compression device to truly deal with banding issues like this.

The other option is to deal with the background in other ways. First off, you could try making your Comp 16bit instead of 8bit so you aren't passing junk to the compressor - garbage in, garbage out, especially in HD land. Try that, if still no love, repost here.

As for your frame rate issues, Deinterlacing in after effects can be a simple matter of going into the interpret footage screen (right-click footage in project window) and selecting lower-field first in the interlace dialog. For the frame rate conversion, put the footage into a comp that is 25fps. Then nest this comp in ANOTHER comp that is 29.97. Use this comp in place of your footage in your master comp.

Post back if none of these resolve well.

DarkstaR1st
03-30-2006, 01:01 PM
Brendan,

Thanx for your help. You're right on the banding of the background image. I was allready changing it to 16bit. And the background image has 2 overlays that will attenuate every flaw even more. Fixed that with seperate color backgrounds and just masking the one over the other. (the orange color overlay is animated over a pink'ish color overlay which in it's turn is animated over a blue'sh white photoshop background).

And i resolved the video interlacing problem almost the same way you stated here. Thanx...

Though, it wasn't the background i was talking about... If you look at the movie in windows it has crisp text. If i watch it via the HD streamer on the LCD HD tv the text becomes a aliased. It's not that tight anymore. Probably interlacing.

Now i'm testing a file rendered with lower fist on in the render settings, and wmv settings the same as above only have variable bitrate to full quality. (forgot to turn on "allow interlaced processing") now the screen jitters. But the tekst looks great.

*ding* Next file is ready with the "allow interlaced processing" turned on :D.

---- edit

Hmm.. still jitters... a lot less but still... Maybe the variable bitrate is a problem... Let's set it back to constant bitrate.

---- edit

HUH???? the screen stopped jittering... It's totally smooth now. BUT, the tekst is aliased again... I'm all out of ideas :(.... Help me think

DarkstaR1st
03-30-2006, 10:12 PM
I've added a picture of the screen where u can clearly see the problem.

http://www.dennist.nl/screen1.jpg

Look at the aliassing of the tekst and base of the LCD tv.... dunno what to do now

DarkstaR1st
04-03-2006, 03:08 PM
Beenieweenies, any ideas...? Any thoughts would be welcome.. :D

beenyweenies
04-04-2006, 06:42 AM
Beenieweenies, any ideas...? Any thoughts would be welcome.. :D

Honestly, it is almost certainly either your tv set or the encoding used. I have seen similar blocky aliasing in HD graphics, and sometimes it comes down to the set itself. Then again, I have rendered out HD graphics using the DVCPro HD codec (which is 100MBps, 2 1/2 times greater than your 40MBps HD box requires) and it has these same aliasing results, so it may not be possible to get perfectly razor-sharp edges with your requirements. I kinda doubt it is.

This is about all I think can think of in terms of fixes:

1. if the screen shot you posted originally is the compression settings you are still using, try changing it to 2-pass instead of single pass. Also, I don't know what that "decoder complexity" option is but you may want to give it a look to make sure the "auto" setting isn't doing something weird.
2. You may be stuck having to merely correct for this problem by giving the problem graphic elements a 1-2 pixel Fast Blur to soften them out. This will look a bit soft, obviously, but might be preferable to having the aliasing.

DarkstaR1st
04-04-2006, 10:06 AM
Thanks for the reply...

The footage that i got with the player is a 1080 60i 5 minute movie of 1.2GB... I don't think it's a WMV so it has to be an MPG.

I've been constantly making an WMV9 file maybe if i render it to an MPG.

But, I can't render an MPG like this from AE (or probably i'm doing something wrong)... It's a bit strange to ask but how do you do it? Render an HD MPG from AE i mean?

beenyweenies
04-04-2006, 05:58 PM
Thanks for the reply...

The footage that i got with the player is a 1080 60i 5 minute movie of 1.2GB... I don't think it's a WMV so it has to be an MPG.

I've been constantly making an WMV9 file maybe if i render it to an MPG.

But, I can't render an MPG like this from AE (or probably i'm doing something wrong)... It's a bit strange to ask but how do you do it? Render an HD MPG from AE i mean?

You might be better off rendering to a higher quality format, for example DVCPRO HD, then compressing that render using external compression software. I'm pretty sure DVCPRO HD is only available on the mac though. If you're not using a mac try outputting to the Animation codec (file will be huge though) then compressing from there.

Going back to your earlier comments regarding the jitter vs. smooth edges, I am wondering if there is an easier way to solve this. When you rendered to lower field first, it takes care of the aliasing but causes your movie to jitter. Does the entire frame jitter or just certain elements? If the entire frame jitters when set to lower field first it could be that you need to try the opposite, upper field first (though I doubt it). If it's just certain elements, such as the video on the tv screen, it could be that those elements need to be de-interlaced in AE before you output.

CGTalk Moderation
04-04-2006, 05:58 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.