PDA

View Full Version : displacement artifacts caused by tris in base mesh


leadheaded
03-17-2006, 10:35 PM
I have a base head mesh with about 118 tris and 858 quads in it. Rendering it with a displacement map generated in ZBrush causes artifacts on every triangle contained in the base mesh as you can see the pictures. One picture is a render with the black dot artifacts on the high res displaced mesh. The other is a baked image with the artifacts baked on every triangle.

I know the ZBrush pipeline docs say to avoid tris if possible. In this case our meshes are bases of a base mesh which has tris so that is not solvable. I was just wondering if there is a way around this. Anyway to tell mental ray to read tris as quads? I tried the convert tris to quads in the approximation editor without any luck.

Any help will be much appreciated.

floze
03-17-2006, 11:28 PM
Do it the other way around: convert your quads to tris. You can do that by chosing Triangulate from the Polygons menu.

leadheaded
03-17-2006, 11:43 PM
Wouldn't having all triangles cause artifacts on every face though? I'll give it a shot.

floze
03-18-2006, 12:05 AM
Wouldn't having all triangles cause artifacts on every face though? I'll give it a shot.
Generally not; mixed tri/quad situations cause that artifacts.

leadheaded
03-18-2006, 12:14 AM
Generally not; mixed tri/quad situations cause that artifacts.

Wow, thanks a lot man. Its great to have people like you around. I wouldn't have tried this otherwise.

Do you have any tips for baking global illumination passes? I am using the fg_occ node for the ambient in a phong material. I have been bumping up the final gather accuracy in the render globals but I haven't gotten extremely smooth results as yet. And I am getting a couple of stray black lines in the baked texture. Some are really huge. What kind of setting would you suggest?

floze
03-18-2006, 03:19 AM
Wow, thanks a lot man. Its great to have people like you around. I wouldn't have tried this otherwise.

Do you have any tips for baking global illumination passes? I am using the fg_occ node for the ambient in a phong material. I have been bumping up the final gather accuracy in the render globals but I haven't gotten extremely smooth results as yet. And I am getting a couple of stray black lines in the baked texture. Some are really huge. What kind of setting would you suggest?
Hmm.. maybe try this thread:
http://forums.cgsociety.org/showthread.php?t=266409

CGTalk Moderation
03-18-2006, 03:19 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.