PDA

View Full Version : QuickTime7 H.264 gamma


Reuben5150
03-10-2006, 09:01 PM
There seems to be a big difference in gamma levels using the new H.264 codec.. its much brighter than anything else, example -

Image and other quicktime codecs -
http://www.btinternet.com/~reuben.flounders/wipimages/Asteroid-demo_img.jpg

and heres the H.264 codec
http://www.btinternet.com/~reuben.flounders/wipimages/Asteroid-demo_qt264.jpg

What can i say, DoH !!!

Anyone else get this ? same on the Mac ?

Reuben

halfworld
03-11-2006, 09:22 AM
Helloo Reuben!

Yeap, this happens on the Mac, it's a bug, something to do with conversion from RGB (computer) to YPP (video) colour spaces causing the gamma shift, depending on how you view it it looks wrong or right. It looks wrong in QT player, but if you play the movie through firefox it looks normal (at least on the mac).

At the moment there is no solution that I'm aware off...
Let me know if you turn one up though!
Ian

By the way! Great Image, I can't wait to see this in action !!!

Reuben5150
03-11-2006, 05:42 PM
Grrrrr, ok thanks, guess i won't be using this codec then.. although i could alter the EI gamma output.

Will post the movie when done :)

Reuben

mitchgates
02-13-2007, 07:19 PM
I've been dealing with the same issue for quite a while, and finally ran across a fix that seems to work. The only downside is it requires QT Pro...

==========================

How to fix an H.264 video conversion 'wash out' issue
By: ccedit (http://www.macosxhints.com/users.php?mode=profile&uid=1047792) on Thu, Jan 4 '07 at 3:54PM PST
I have also searched high and low for a solution to the "washed out" look. After an almost sleepless night I came across the fix without having to mess around with color profiles. I'm working from a PC so some of the commands might be slightly different.

After you create the QuickTime/h.264 file, open it up in QuickTime and select "Show Movie Properties." Highlight the video track then click on the "Visual Settings" tab. Towards the bottom left you should see "Transparency" with a drop-down box next to it. Select "Blend" from the menu then move the "Transparency Level" slider to 100%. Right after that, choose "Straight Alpha" from the same drop-down and close the properties window. AND finally, "Save."

So far, it's worked like a charm for me; hope it does the same for you.

animalunae
09-05-2007, 01:03 PM
...So far, it's worked like a charm for me; hope it does the same for you.

Wonderful, it DOES! Thank you kindly, this has bugged me in the past!

moka.studio
10-05-2007, 12:12 PM
I've been dealing with the same issue for quite a while, and finally ran across a fix that seems to work. The only downside is it requires QT Pro...

So far, it's worked like a charm for me; hope it does the same for you.


thanks a lot, this works perfect

Digiegg
06-16-2008, 05:47 PM
NICE! I worked!Thanks alot dude!!


I've been dealing with the same issue for quite a while, and finally ran across a fix that seems to work. The only downside is it requires QT Pro...

==========================

How to fix an H.264 video conversion 'wash out' issue
By: ccedit (http://www.macosxhints.com/users.php?mode=profile&uid=1047792) on Thu, Jan 4 '07 at 3:54PM PST
I have also searched high and low for a solution to the "washed out" look. After an almost sleepless night I came across the fix without having to mess around with color profiles. I'm working from a PC so some of the commands might be slightly different.

After you create the QuickTime/h.264 file, open it up in QuickTime and select "Show Movie Properties." Highlight the video track then click on the "Visual Settings" tab. Towards the bottom left you should see "Transparency" with a drop-down box next to it. Select "Blend" from the menu then move the "Transparency Level" slider to 100%. Right after that, choose "Straight Alpha" from the same drop-down and close the properties window. AND finally, "Save."

So far, it's worked like a charm for me; hope it does the same for you.

SpaXe
07-26-2008, 06:24 AM
That workaround only works as long as you don't play full screen. It's rather choppy when you play full screen with that setting.

The closest thing I've got is to go to the A/V control and turn up the contrast. =(

CGTalk Moderation
07-26-2008, 06:24 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.