PDA

View Full Version : Animation flickering.. how?


worx3d
03-09-2006, 08:04 PM
I need to render an animation at 720x480 that will be used on TV. Rendering with the broadcast setting doesn't solve the problem: flickering is intense. I have no animated textures or anything fancy, I just have a simple scene of a flying cam on the woods.

Please, can anyone with animation expertise with Vue share the optimal settings to avoid the flickering? is there any tricks or special settings? antialias settings? I really need to render this soon as the deadline approaches and I'm new with Vue (using Infinite on a mac).

T.I.A.

-joel

mdunakin
03-09-2006, 09:43 PM
I think first you need do a search in this forum for "flickering", as there
are several threads already on this topic that should help you out fairly well.
And if you still have specific questions then ask away :)

...........md :)

.

Phoul
03-09-2006, 10:13 PM
For animations? Boost OAA and uncheck TAA (see the attachment).
Also, in global illumination scenes, if many details (e.g; forest) in large shot, enter a good illumination quality boost: 1 to 4.
Hope that's help.

http://www.renderosity.com/photos/MSG2/Message2605385.jpg
http://www.renderosity.com/messages.ez?Form.ShowMessage=2604073

worx3d
03-09-2006, 10:26 PM
thanks to both!...

mdunakin, I did search but couldn't find something very informative, perhaps I didn't search well.

Philippe, thanks a lot for the screenshot and comments, better an image than a thousand words. I will try your recommendations right away.

joel

mdunakin
03-09-2006, 11:48 PM
Yeah, I would of posted better info, but there really is soooo many reasons
that can cause flickering and this same subject has been brought up several
times (probably a LOT of times) and so I figured you'd get better results from
a search, then from me trying to recall all the different answers people have
had over time, and there ARE a lot of them, including the one just shown above.
Just adds more good stuff to this subject.
Thanx for that to, Phoul :)

And yes, in those other threads on this subject, they also have
images as well, so yes, they do more then just words is my point :)
Maybe not as much as you might want, but some of them show screen shots.
I haven't gone through these too closely, but there might be more info in them
to add to what's been said here already, I don't know, but it's worth a look?

Here's a few:
http://forums.cgsociety.org/showthread.php?t=221417&highlight=flicker
http://forums.cgsociety.org/showthread.php?t=294220&highlight=flicker
http://forums.cgsociety.org/showthread.php?t=288241&highlight=flicker
http://forums.cgsociety.org/showthread.php?t=287341&highlight=flicker
http://forums.cgsociety.org/showthread.php?t=285167&highlight=flicker
http://forums.cgsociety.org/showthread.php?t=270718&highlight=flicker
http://forums.cgsociety.org/showthread.php?t=242188&highlight=flicker

But, if what was just said helps and solves your problems, then cool :)
And if you are able, let us see your results when and if you can?

Thanx and good luck..........md :)

.

worx3d
03-10-2006, 12:07 AM
Wow, thanks again Mark, it seems I didn't do my homework right, sorry about that. I'm going to check all those threads to see what I can gather from them and I will be happy to show my results as soon as I get it to work the way I want.

thanks and see ya around

Joel

mdunakin
03-10-2006, 12:14 AM
Cool and no probs :)
And I appreciate what Phoul posted,
as that's yet another great screen shot and tips.

I can't wait to see what your finals turn out like too!

Stills are nice, but nothing beats a good animation.

Some day, I hope to finish an animation..........md :)

.

worx3d
03-10-2006, 04:45 PM
So I left the G5 rendering all night with the settings Philippe suggested, and the flicker persists. Now I have read the other threads that Mark kindly pointed to me and a different approach is to render the frames twice as large with lower settings (Final, or Broadcast). I will try rendering a few frames this way and report back. It's really dissapointing to see this problem in Vue. It seems like a program with lots of potential, but with little use for animators.

worx3d
03-10-2006, 05:42 PM
I rendered 8 frames at 1440 x 960, and scaled them back to 720x480 in After Effects 7. Flicker still there. I'm giving up on this software for now, as the deadline approaches quickly and need to do a lot of work on Electric Image now. I need to create a forest by hand :( ... and I thought Vue was the solution!

mdunakin
03-10-2006, 07:09 PM
Ahhh... that's too bad for ya :(

If you could of maybe posted an image (one of the bad frames that looks bad in the animation)
then maybe we could of helped you out some more to see if there might be a sollution for ya?

I like a challenge and I also beleave there are answers to all these issues,
but not seeing what you are working with, makes figuring out help for you much harder.
I know that if it is for a job though, that you may not be able to post any of the work,
but if you could, then that would sure help us to help you?

There are still some other things to try that can get rid of those flickering things.
Some have to do with lighting.
I had these same issues with my first test animation and I wasn't able to find a
sollution either, at the time, and then I tried changing the way the plants themselves
handled light and I almost got rid of all the flickering by doing a few simple things.
I can't exactly remember them all, but if I needed to, I could figure it out again for ya.
Meaning, I won't spend any time on this if you are already out of time and need to move on?
But, if I remember correctly, what I did was one or several or all of these things:
I may have changed the surfaces of the plants to be double sided (which they should
already be defaulted to that, but make sure that the One Sided option is NOT checked.
I may have changed the amount of material highlights from their defaults,
which are ALWAYS set waaayyyy toooo high (IMO) down to near zero.
I may also have changed the changed the Global Highlights from their
normally 34% amount to something more relistic, like 10%.
You may also want to adjust the amount of Defuse/Ambient (under the Effects tab) in
the Material Editor for each plant/object, by lowering them down some, mostly the Ambient.
And do this for all or most of your objects, including the Terrain itself.
And be sure to NOT use a Procedural Terrain, if at all possible as these
are famous for causing flickering problems and issues of this type.

And I just checked out my old scene, just to make sure of these things, and yes,
these are pretty much most of the things I did, though there were others too.
Such as, I set my Camera to use a Motion Blur, set to 20% or you could go higher if needed.
Motion Blur alone will help immensely in elliminating flicker problems.

I'll see if I can find the old animation and then render out a
new version for you to check out the differences between the two.

I do feel for ya, but I want you to know, that there ARE ways to get around this problem.
But, I also can understand deadlines, as I've been on them many times myself.
You have to do what you have to do.

I'll be back a little later............................md :)

.

worx3d
03-10-2006, 07:52 PM
Thanks Mark, if I can solve it today I might be able to render something this weekend and be on time for the deadline, but I'm not sure if I should better dedicate my time to a package I know a lot more, Electric Image. The thing with EI is that it is a general purpose 3D package and making a forest could be laborious (unless I buy some plugins, which I don't want to do).

anyways, here's a frame of the animation. This frame has the settings Philippe suggested (although I don't see a better AA there!):

http://www.quatroproducciones.com/frame_000027.jpg

and a movie can be found here:

http://www.quatroproducciones.com/paisaje_test.mov

thanks again for all the advice.

mdunakin
03-10-2006, 08:30 PM
Hmm... I pretty much didn't see anything really wrong with that animation,
other then the overall quality of the animation (QT) itself, but, are these
the areas in that particular animation that you think are problematic?

http://www.md-arts.com/Vue/VueAnimationFlickering_01.jpg

And these here deffinately look like hot spots to me:
http://www.md-arts.com/Vue/frame_000027_01.jpg

I would make those changes to the Materials for all of these as I have described above.
Wayyy tooo much Highlights in them and this will stand out big time.
But!, it isn't so much of them being Highlights, as that they will add to or directly be the
cause of, the clashing between pixels and thus contribute to the sparkle dots, or flickering.

See the bark on the Trees.
The rocks in the Ground Material, I can't tell if those are actual rocks
in an Eco System or just Bump Textures in the Material for the Ground?
Either way, they need to be lessened up some in the Highlight department.
And the leaves could be brought down some, at least on that one tree.
Same with the tall grass/weeds that are in the red rectangle.

Also, the base image quality of this latest image you just posted (not the animation sample)
looks kind of on the less quality, as I can see jaggies (stair-casing) in the grass plant front and center.

This should be fixed with either the AA somewhere as has been suggested, or maybe a slight bit more blur?

Some of this can be fixed another way too, "without" having to change ANY AA,
by changing the Contrast in the Material Editor under the Effects Tab.
Make it slightly more on the Soft side and LESS on the Contrast side.
Do a few test image renders and make appropriot adjustments untill it looks better.
This last thing I just mentioned, people always overlook or just don't even know or think about.

And lastly, you might even need to modify your Environment (Atmosphere/Lighting) a bit
to blend the overall lighting affect of the scene and that can smooth things out a little more.

Let me know if any of this helps or not?

I sure hope that things will work out for you :)

BTW, so far, I like the animation, or at least that little sample version you made :)
I think an animation going through or from/over the trees scene you just posted,
will look awesome, if these issues can be worked out.

............md :)

.

Kevin Sanderson
03-10-2006, 09:24 PM
Lots of programs have that shimmer with procedurals. You might want to try motion blur (I think that's what Mark means) to see if that helps. It will kick up your render times a bit, but it might be worth it to try a test render. Or you might also do this... give the frames a very subtle soft blur in a comp program or run a batch through Photoshop. By the time it's on video, you'll never see it. Film and video are never as sharp (except HD) as CG is.

Kevin

worx3d
03-10-2006, 10:19 PM
On the QT movie you got it right, the flicker on the areas you marked is the problem. That's not a QT compression artifact, the uncompressed render looks very much the same.

On the still image, the flicker happens mainly on the trees (leaves), and a little on the ground.

I will follow your tips and see what I get.

thanks

drzorn
02-13-2007, 12:12 AM
HI!

i made custom settings for the most flickerfree images i ever made.
here the settings:

o = means unchecked
x = means checked


x Apply materials
x Enable sub-rays
x Trace cast shadows
x Trace reflections
x Trace transperency
under edit:
Max trace level ---> 5
Max total internal reflection level ----> 5
x Enable super-sampling
x Soft shadows
x Blurred reflections
x Blurred transperency
x Depth of field
x Enable motion bluring
under edit:
x Distributed ray-tracing

the rest is unchecked except Object antialiasing!
advanced effectsquality is at 77%
under edit, "Optimize indirect lightning on plants" is checked.
"Photon maps" everything is unchecked.

under edit of the antialiasing settings:
OAA is checked.
x Systematic
Min Subrays ---> 15
Max Subrays ----> 50
Qualitytreshhold ----> 90%
Texturefiltering ----> 5%
rest is unchecked because TAA is disabled.

in the additional anmation render settings only "Deterministic antialiasing" is checked.
the restof these options reduces the quality of image!!! maybe a bit of "distance bluring". A BIT!

ok i have to say my szene has no GI, AO or GR ! and i tested it only on trees texture and other eco objects. and there is still a restflicker. but not as much as in every other setting i triied. i hope you can use that and i could help you! and never give up! :)

CGTalk Moderation
02-13-2007, 12:12 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.