PDA

View Full Version : small .mpj bug


MoodyB
02-27-2006, 06:29 PM
Hey all,

EDIT - missed out one step

Steps to recreate :

1 - make sure 'project file query ' and ' save images to project file ' are on

2 - load 2 or more obejcts into Messiah, they must have unique texture maps applied

3 - save the scene as an .mpj - say yes to the requester that pops up

4 - quit and restart Messiah, then turn off ' save images to project file '

5 - load in the .mpj you just saved and save it again as a different version - say no to the requester. If you check the filesizes of the 2 mpj's, both will be identical, even though one isn't meant to have any images saved to it.

6 - quit / restart Messiah, and load in the mpj you just saved. Check the object textures' and you should find that all objects now have the same texture applied ( it should be the texture that's on the mesh that was loaded first ), . The texturemap block shows the right filename, but the wrong image.

6b - load in any texture to any object.

7 - go to the texturemap block of any material with the wrong texture image shown and select ' reload image ' from the popup. 8 times out of 10, Messiah will crash.

Not a big issue, but an annoying one if you're not aware of it ( like I wasn't yesterday )

Wegg
02-28-2006, 03:20 PM
Make sure to send things like this through the propper support channels.

techsupport@projectmessiah.com (techsupport@projectmessiah.com)

MoodyB
02-28-2006, 06:13 PM
Will do Wegg, thanks.

CGTalk Moderation
02-28-2006, 06:13 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.