PDA

View Full Version : Global Illuminaiton Bleed Problem - Bad Bleed!


Matt Grdinic
02-21-2006, 10:54 PM
Perhaps someone can help me fix this:
http://img219.imageshack.us/img219/9921/problem0hy.gif

When you look at that image you'll notice the Map Visualizer says no photons are being absorbed beyond where the two planes intersect, yet in a render their is a ton of bleed anyway.

This behavior is present with maya and mentalRay shaders (my example scene uses only mentalRay dgs materials, both for the material and photon shaders, but is the same with regular maya blinn, for example).

Increasing Global Illum Accuracy and Photon Volume Accuracy in render globals has no effect (fixing the problem that is).

The only light used is a simple point light with a physical_light shader attached. Changing from area light and tweaking shadow attributes had no effect.

Surface direction seems to have no effect (for both nurbs direction and poly normals).

It doesn't seem to be a geometry issue as i can detach the surface in the problem area and the bleed looks the same.

Yes, the surfaces are tight together : ) That said, the effect is the same even when the geometry clearly intersects.


Hmm, that's about it. Anyway, I know I could just build the scene geometry different and cover areas like that up, but it bugs me in principal...this behavior simply can't be right. Anyone have an idea?

LehaS
02-22-2006, 07:00 AM
Just a guess but..
Can`t it be that your photon radius is too large?

Matt Grdinic
02-23-2006, 03:51 AM
Just a guess but..
Can`t it be that your photon radius is too large?

That's a good suggestion.

I tried several variations on that theme, all without luck. As I'm sure most are aware, when you make the radius too small you inevitably introduce the 'speckle' or 'star-field' effect. In short, I'm not able to find a suitable medium between radius and noise. However, it should be noted that the amount of bleed did change a bit, meaning we may be on the right track.

UPDATE: I played around a bit more, and interestingly enough, ticking on final gather takes care of the problem, only to introduce another one! To explain, without FG the light bleeds like the original picture shows; but when you turn on FG the color bleed actually transfers from the large plane to the small ones. It seems to flip.

What i find interesting is more people don't seem to have this problem. It would seem that anytime you want to have a light area inside of a dark one this problem creeps up. Surly their must be some fix.

bgawboy
02-23-2006, 11:52 PM
When the GI radius is larger than the thickness of your wall, this can happen.
If it is possible to change the geometry and still provide the look you want, then
increase the thickness in the wall, to counteract how much you may have to reduce
the photon map (GI) radius.

Perhaps there is a simpler solution. If you want no GI on one of the surfaces, try turning off GI receiving on that object.


FG has similar radii to control. FG Max radius is used to look for FG points to interpolate. Within this radius, mental ray will use a heuristic to try to get rid of potentially wrong FG points such as those whose angle of illumination might not match the sample point that well. The FG min radius tells mental ray to use all the FG points within this radius, except those with obviously reversed normals.

Improvement from FG may indicate smaller FG radius than GI radius.

CGTalk Moderation
02-23-2006, 11:52 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.