PDA

View Full Version : Problems with Binding my Robot Character


raijinnfury
02-20-2006, 10:34 PM
I'm a student so I'm kind of new to the whole binding/rigging process. But I have my rig and its all set up with a toe roll and all that, but what I want to do is only do smooth bind in some parts like his elbow and his feet, and just do parenting to the rest of the joints (like I said my character is a robot so some of the joints just move like hinge joints, no need to do any deformations).

But what happens is that for instance when I smooth bind the elbow, the arm basically detaches from the shoulder (they are two separate objects). I can include some screenshots to help show this.

So my question is, should I smooth bind everything first and then go back and detach skin on some of the pieces and parent them? Or should I just redo the whole rig? Right now I have parented my objects to the joints before smooth binding.

john_homer
02-20-2006, 10:51 PM
never parent geo to a joint and then bind it in any way. this will cause it to move twice.

just smoothBind what you want smooth bound and rigid bind or parent the rest... or just smoothBind it all and set all the weights to be on 1 joint if you want it rigid...

.j

raijinnfury
02-21-2006, 03:05 AM
Thanks so much for the quick response! That's why I love these forums. :thumbsup:

I'll have to try that sometime soon (not this week though, way too busy!) I'll let everyone know if I have any more problems.

CGTalk Moderation
02-21-2006, 03:05 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.