PDA

View Full Version : Displacement and shadows and spec, oh my


jgj
02-19-2006, 09:52 PM
I'm almost certain this is a dumb question :), but I've searched the forums and the docs to no avail...

This is a render of a metanurb'd plane, with a Noise node providing displacement. The obvious problems are A) the shadows seem to be calculated based on a much lower res "Sub Level" than that which is actually in use (20), and B) the specular highlight is like what would be on the totally undisplaced surface, i.e.: flat, and not taking into accout the bumps.

Is there something I'm missing in order to get correct shadows and spec highlights on a displaced surface?

-Jim

rush123
02-19-2006, 10:08 PM
Jim

Have you set your subdivision level, check docs under setup->items->Metanurbs

R

jgj
02-19-2006, 11:45 PM
Yup. (Thanks for the reminder :)) I tried values between 0 and 10 (it was set to 3, the default), which oddly made no difference to the rendered image.

The surface "Displacement / Appearance" "Sub Level" is set to 20, and "Max Displace" is set to 10. Changes to "Render Type" make no difference.

-Jim

jgj
02-20-2006, 07:30 AM
Figured it out...

Too much "Max Displace" (Surface), and too little "Bump" (Material).

Image in first post had Max Displace = 10, and Bump = 1.
Changed Max Displace to 0.5 and Bump to 15, and shadows and specular are fixed. (Attached image.)

The upshot, I think, is that shadows and specular depend primarily (or maybe totally?) on a Materials's Bump setting, while Max Displace, though it has to have some value, should perhaps be a small amount in proportion.

Obviously, there's alot going on in the interdependence of those two settings... there really should be a more detailed explanation than what's available currently in the docs. Without knowing beforehand, or through tedious trial and error, it's quite possible to put in numbers that really make a mess of things. :)

-Jim

ThomasHelzle
02-20-2006, 04:18 PM
AFAIK Max Displacement is meant to be set to 1.0 to turn displacement on and to 0.0 to turn it of. Everything else do with the bump setting.

And please don't ask me why it works that way ;)

Best regards,

CGTalk Moderation
02-20-2006, 04:18 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.