PDA

View Full Version : setAttr imageFile error


Goon
02-19-2006, 08:56 PM
'ello

Working with the buttonManip command, and am running into an interesting bug.
Attempting to use setAttr to set the iconFile (which allows a bmp image to be displayed as an icon in the viewport) results in the following error:
// Error: line 1: Failed to open IFF file for reading : C:/DOCUME~1/Goon/LOCALS~1/Temp//maya18880103EDC8.iff //
This is not the image file that I was specifying. Here is the command I am using :
setAttr -type "string" Manipulator3.iconFile "D:\\MyDocuments\\Maya\\7.0\\prefs\\icons\\zooTriggered_1.bmp\"\;";

Any ideas?
Also, does anyone use this command much? It looks cool, but seems a bit buggy. the -icon flag doesn't work, and copy/pasting into the .script attribute seems to break after a few times.

Furthermore, there's a little square beneath the buttonManip command button, that you can use to move the buttonManip around. I'd like to make that dissapear, but the node for it doesn't seem to exist, and it doesn't seem to be a part of the actual buttonManip. What the hell?

deo01
02-20-2006, 01:43 AM
Hey,
Could be that your bmp file wasn't saved in a format that maya can read... you will get the same error if you try to connect any other type of image that is not supported.
Save your image in photoshop, as bmp and in the BMP options choose: File Format->Windows, Depth->24 Bit. It should work ok.

Goon
02-20-2006, 02:45 AM
thanks, but I am quite sure that that is not the case. I have used that image file and several others several times through manual entry of the path in the AE. It just won't work using code

CGTalk Moderation
02-20-2006, 02:45 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.