PDA

View Full Version : I cant get my alpha matte to erase 3d elements


Tris3d
02-08-2006, 04:45 PM
Hey guys! Just wondering if you can help with a problem i've got?

Basically I am creating a special effect where i have a cg creature walking on some real background footage. I am rendering the 3d elements in max and compositing in after effects.

Now at one point the creature needs to walk behind some trees in the footage so I created some tree objects in max and applied a matte/shadow material to them and rendered the alpha. Now for some reason i cant seem to apply it in after effects so that it just wipes away the 3d elements where the trees are?? I've tried Effects>channel>Set matte, i've tried track matte and all the different settings but i cant seem to get rid of just the section of trees. Its a nightmare!! Please can anyone help?

thanks

Tris :oops:

jussing
02-08-2006, 05:07 PM
It sounds like the problem is, you render elements and mattes in two seperate passes.

There are two ways to do it:

Apply "matte" material to the trees, and render them in the same pass as the creature. This will "cut out" the creature's alpha channel where the trees are automatically, and you won't even have to bother with it in compositing.
Render creature and tree mattes as two seperate passes, but don't use matte material on the trees (because a matte material alpha won't show in the render, that's what the matte material does)
Good luck,
- Jonas

Mylenium
02-08-2006, 05:26 PM
Hey guys! Just wondering if you can help with a problem i've got?

Basically I am creating a special effect where i have a cg creature walking on some real background footage. I am rendering the 3d elements in max and compositing in after effects.

Now at one point the creature needs to walk behind some trees in the footage so I created some tree objects in max and applied a matte/shadow material to them and rendered the alpha. Now for some reason i cant seem to apply it in after effects so that it just wipes away the 3d elements where the trees are?? I've tried Effects>channel>Set matte, i've tried track matte and all the different settings but i cant seem to get rid of just the section of trees. Its a nightmare!! Please can anyone help?

thanks

Tris :oops:

Yeah, I also think this is more a problem of how you render your layers rather than how you compose them (don't use MAX, so I can't help you there). Have you tried inverting your channels using the Invert effect, not the matte settings? Assuming you didn't use a completely black matte material, you might also be able to extract usable info by using the Shift channel effect in combination with the Levels tool.

Mylenium

Tris3d
02-08-2006, 05:40 PM
Thanks guys! Yeah I think my problem is where i am setting up the matte! its like i have two colours on my matte! White and black, the white is see through and the black is visible yet i need the white to cut away the 3d image and the black to be non visible to see the background on a lower layer. When i invert i can see the background on the lower layer but i have a solid black tree image. Its driving me crazy!


p.s what do you guys use? Channel>set matte or the track matte on the layers? Or are they the same?

Thanks so much for the help!

jussing
02-08-2006, 06:07 PM
You need to select matte here:

http://www.duck.dk/bin/cgtalk_matte.jpg

(where Comp 2 is your matte, and Comp 1 is your creature)

Cheers,
- Jonas

CGTalk Moderation
02-08-2006, 06:07 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.