PDA

View Full Version : i`m having problems with Comet`s pose deformer..


yolao
02-07-2006, 02:30 PM
hi

i`m using Comet`s plugin pose deformer to make some corective shapes, and is the first time that i use this plugin...i`m using as a guide this tutorial http://www.tokeru.com/twiki/bin/view/Main/MayaPoseDeformer
everything works fine but after i sculpt the corective shape the things don`t work well.

the joint that i turn was the elbow joint, so i put that one as the influence that i move, i also put that one as the "parent the poseReader"..and finally i name the pose elbowBend and hit "create/edit pose"..

after a while i get an small cone in the joint, the bad thing is that when i turn the elbow to it`s original position the corrective shape remain all the time.....an the YELLOW text alway remain yellow...i know that the yellow text numbers should change while i moving the joint but it don`t happen in my case.

what can i do.?

thanks in advance

Lomax
02-07-2006, 02:57 PM
You don't want to parent the pose reader to the joint it's reading. It needs to be under that joint's parent to work properly (the shoulder, or a twist joint, for example).

yolao
02-07-2006, 03:24 PM
You don't want to parent the pose reader to the joint it's reading. It needs to be under that joint's parent to work properly (the shoulder, or a twist joint, for example).

thanks Jared...

yeah...i use as a parent the shoulder and now it works...the only problem that i have is that from the bind pose to the elbow bend is a long way and i feel that i`m not having enough deformation in the middle of the way...

is there a way to add some inbetween deformation with comet`s plug in?...i have a plugin made by cgtoolkit call cgTKshapeBuilder that lets you set keys from the bind pose to the final bend pose...the problem is that it only allows doing this in one direction X,Y or Z..

thanks again

ahhhh...and important question:

if i made all this changes and corrective shapes in one side...is there a way to mirror all this to the other side?

Lomax
02-07-2006, 04:21 PM
The first thing I would check would be the max angle on the pose reader. By default, it's set at 45. But if the elbow pose is 90, the max angle may also need to be 90, otherwise the correction will only start to blend in half-way.
You can also add as many poses as you like, but you'll still need to adjust the max angle on the cones, for proper blending.

Unfortunately, I haven't had much luck mirroring the shapes. Usually I just make a copy of the mesh, flip the scale, and then use it as a guide for sculpting the original mesh.

yolao
02-07-2006, 04:38 PM
thanks Jared...this are my first steps in rigging and using this plugin...and the plugin looks fantastic.

cheers

johnarkensaw
02-08-2006, 09:25 PM
I tried using this plugin a few months back... the concept is very good, and based on the demonstrative video it should work very well... but it isn't as straightforward as it seems! It would be nice if a more detailed tutorial/documentation became available on how to properly use it... especially when adding multiple pose deforms to a joint to cover different angles/situations they don't seem to get along... they cancel each other out, or cause unexpected deformations.. and adding pose deformers to different joints also had problems...

I have no doubt that all these problems were my own fault and have solutions (perhaps obvious ones!), but I had no luck getting to the bottom of it... which saddens me as this is a potentially great solution for rigging problems, without having to get into muscle systems (which can be too much sometimes, or simply not available/ a viable option). :sad:

ashishdantu
02-25-2006, 10:52 AM
hi ppl / comet ,

i have used PSD to correct my mesh fantastic plugin...

but have been also getting crashes .....my scene if the mesh has clusters and i try and edit the cluster weights.. maya simply vanishes.. i tried removing the PSD node and tried the cluster weighting, it works fine.

and when i edit skin weights,( i'm using david waldens skinning tools ) and if it has a poseDeformer on it, maya crashes.. if i go to the paint mode (tab) and select any bone and if i say "isolate selection", maya crashes...

i have a cloth - shorts object and i used PSD to correct it when the leg raises to right from 0 to -110.. works fine... but when the bone returns to 0, the mesh is still deformed - doesnt return to default.. i tried chaning the read-axis, rotated the pose_reader to all posssible angles.. still it is same. now i worked around by SDKing the psd 's envelope to the thigh bone's rotation.. works.. but it not a straight forward method..

in the input stack, when i drag the PSD node below the skin cluster, it errors > "Error: line 1: Problems occurred with dependency graph setup." and if i drag the skin on to the PSD it warns > "Warning: line 1: LEG_PSD_CBs and skinCluster53 are already in the specified order." is this PSD to be sitting on top of the skin or is 'nt the order of any importance ?

anyone got the same probs ? any idea what might be causing these ?
-rgds,

theflatlander
07-04-2006, 10:41 PM
yeah Iīm having some problems, my skin doesnīt want to go back to itīs original shape after I have shaped it! really disturbing, does anyone know why this happens or how I can fix it? It seems like a lot of people are having the same problem!

marckury
01-30-2007, 02:40 AM
same problem here...sometimes... maybe its the pose reader problem because is in the bad joint or whatever parented but i dont know where to parent ! im trying with all joints and influences around the asked moved influences for deformations, i only get good result in knee influence and arm but cant get it in shoulder, its quite annoying achieve the perfect pose and when apply crash...:sad:

sporadic
01-30-2007, 04:09 PM
For those having problems with the skin not going to the default shape, I have one thought.

If the default joint position is within the cone of any of your corrective poses, the corrective poses might be having some influence on the final shape. See, when multiple poses match a joint position (the joint position is within their cone), it weights them so that the weight sums to 1.0, and applies that much of each pose. To deal with this, the first thing to do (if you haven't already) is create a default pose in your set of poses. This is recommended in the tutorial, so you're probably ok there. Next, make sure the cone of every other pose does not include the default position of the joint. Since the default pose will be the only pose in default position, you will get no deformation.

A quick tip for getting good pose to pose deformation: When making a series of poses along a single rotation (elbow bend, say), make the cone angle just a little less than the separation between the poses. For example, if the poses are spaced at 15 degrees, make the cone angle 14.9. This will ensure that the sculpted pose is exactly what you see at that angle, but the phasing will be essentially continuous. I used to make the angle double, so that several poses were always in effect, and while that gives smooth deformation, the mesh never came to exactly what I sculpted, which was troublesome.

marckury
02-02-2007, 09:55 PM
im trying to calculate some cloth on my character with some pose deformers and is extremely slow calculating , even when i convert character to be a collider is more slow than usual ... im afraid thinking if now i cant make some cloth calculation on pose deformers! is it normal???

CGTalk Moderation
02-02-2007, 09:55 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.