PDA

View Full Version : UV help ZBrush / Maya


AlpahKaneda
01-13-2006, 05:52 AM
Hello, I have a problem that is putting my work at a hault:sad: I was wondering if there was help out ther?:D

If you dont understand what I am talking about, please just tell me so that I can try to explain better.

I have created a highly detailed character in Modo, and wish it give it nice enhancments using ZBrush...then render in Maya using Mental Ray (doing an animation).
The problem is that since my character is so detailed, doing accurate UV's with no overlaps is too time consuming and its wrecking my life.

My solution was just to use Maya's Automatic mapping just to layout nice UV's without any overlaping. So I did that...then tested it all out by painting some detail in Z Brush...created a Normal map...then went back into Maya. I applied the Normal map properly to my model and rendered it out...at first I thought everything was good...but then I realized....I have a load of creases caused by the UV's edges:sad: I assumed that since I painted the Normal map in ZBrush it would be Seamless b/c I dont have to break up my strokes. WRONG!

So now my only choice it seems is to spend 100 years doing UV's for my character...but if anyone can help me get rid of the seams...or suggest another way to go about getting good results I will be ther slave!

Thank you soo very much for any help:thumbsup:

eblondin
01-13-2006, 05:19 PM
First of all you should make sure that the normal map you our outputting from zbrush is the correct setup for maya. Different programs read normal maps differently ie max and maya. If you are using zbrush then you should with out any question use zmapper to make your normal maps. Zmapper has presets for making tangent space normal maps in maya. Make sure you are using those presets for maya.

Also you can check how your normal map looks applied to your model in zbrush with zmapper. If it looks right in zmapper then you can get it to look right in maya.

heres a link for zmapper if you have not been using it.


http://pixologic.com/zbrush/class/zmapper2.html

read the documentaion on it as well if you have not done so already. Hope this helps

benclark
01-14-2006, 04:40 PM
Have you tried assigning the UVs in Zbrush? (The GUV tile option i think)


I dont know what version of maya you are using but if its version 7 then you can just use UnfoldUVs, keep any seems to the back and try and minimise them manually.

There are loads of posts at zbrush central about getting rid of seams too

Good Luck

Beanmaster
01-14-2006, 04:55 PM
Hi, when you import the normal map into maya in the file settings under effects set the filter to 0.1. The default setting is 1.0 and you will get seams with this setting.
Hope that helps.

detached
01-14-2006, 08:10 PM
I have had this happen in the past also. Not sure what causes it to occur but its a real pain. I found that turning off the pixel filter type for the image file fixes the problem. Its been a few months since I've ran into this problem but if I'm remembering correctly, that will do the trick. Let me know if that helps at all.

Brian

AlpahKaneda
01-16-2006, 12:20 AM
WOW thank you soo much to each and everyone, you all helped me with the problem..and also expanded my knowledge on how to do soo much more!

Thanks alot to you all, I really appreciate it:thumbsup: :buttrock:


THANKS THANKS THANKS

CGTalk Moderation
01-16-2006, 12:20 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.