PDA

View Full Version : problems with netrenders saving path


v-empire
11-11-2005, 10:07 PM
Hi
after reading thru various threads I managed that the netrender clients are able to find the
textures for the scene on a shared drive. I did this by copying the cinema4d prefs over the client prefs.
Is there another way which works easier and better for shared drives?

and second:
I can´t manage to get the clients to save the output images to the location selected in the
render settings. The pictures always end up in the cinema4d/user/administrator directory

Any advice would be greatly appreciated

Thanks
Holger

Srek
11-12-2005, 08:37 AM
The main difference between Net Rendering and the usual rendering is that the Net server is doing the assembling of the final images or animation. The client only provides the raw image in B3D or TIFF format and the server will convert/assemble it to the target format. The Rendersettings have no influence here.
Cheers
Björn

v-empire
11-12-2005, 10:33 AM
Ok I got that. Thanks

I solved the problem by copying the c4d server to the fileserver-machine. So at least
the files are now going to the storage volume I want them to.

But I still got some trouble with the textures.
If I use the texturepaths function in the preferences, I get the machines to find the textures under a certain directory. So far so good.
BUt what if I have a lot of Picturesequences as textures? The ten directorys in the texturepath preset will never be enough because every imagesequence occupies a full folder. And if I try to use more than 10 preset texturepaths I have to copy presets to all clients for every scene that uses different folders.

Is it possible to use a top directory in the texturepaths presets like z:// so that every possible directory on this disc will be taken into consideration??

By the way: I can´t understand that it seems to be impossible to get the textures in a scene from a mapped network-drive that all the machines have access to. At least in my case it won´t work.

Thanks for any help
Holger

Srek
11-12-2005, 11:31 AM
The 10 available paths are searched completely for all subdirectories. If you put the root of a drive in one of them the complete drive will be searched for the texture. You have to make sure that youre textures have unique names, since there is no way for CINEMA to tell
\\myserver\textures\buildings\background.tiff
from
\\myserver\textures\plants\background.tiff
if you use \\myserver\textures\ as a path entry.
Alternativley you can use absolute paths for textures within your scene, you just have to make sure that each and every client has the same access to those paths.

Hope this helps
Björn

v-empire
11-12-2005, 11:42 AM
Thanks,
but absolute paths is what I tried without success.

I´ve got a networkdrive Z: which is definitely accessable from each machine (I´m shure because it works for lightwave netrendering)

I loaded textures with an absolute paths like:
Z:\selecttexture\180grad-landscape\bluestone.tga

but I got the usual missing texture message in the netrender manager.

What could be the reason? Is it possible that cinema relinked the pathes on saving??

Thanks
Holger

CGTalk Moderation
11-12-2005, 11:42 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.