PDA

View Full Version : Edit sphere: dual axis controler (noob question)


dOMINUSMess
11-10-2005, 12:23 PM
Hi,
I'm trying to figure out how to use the dual axis controler "M" on the edit sphere: it works fine in front view ("Y" and "X" axes), but in left view when dragging the "M" dual axis controler, the movement is restricted to either "Y" or "Z" but never both?

I'm using a Wacom tablet, if that's important.
I've searched the docs and the forums, but without result.
Thanks.

stooch
11-10-2005, 02:44 PM
umm thats a feature in pretty much every program. in side view you are restrited to that plane. if you want to move it anyway, use the transform boxes on the bottom left.

dOMINUSMess
11-10-2005, 03:06 PM
I'm not sure what you mean and I'm not sure if you get what I meant.

I'm doing the docs tutorials, and when using the edit sphere to move an object (e.g. left foot), then it's possible to move that object in two directions at once by grabbing the "M" on the edit sphere.

In the front viewport that means that you can move the object in Y and X directions at the same time by grabbing the "M" on the edit sphere.
In the left viewport that means that you can move the object in Y and Z directions at the same time by grabbing the "M" on the edit sphere.

I've seen both examples working in the animated gifs in the tutorials.

But: when I try to move an object in two directions at the same time with the "M" of the edit sphere, it works in the front/back viewports, but it does NOT work in the left/right viewports!??
I mean: (in the left/right vieports) when Y was selected, then trying to move with M is being restricted to the Y direction, and when Z was selected, the trying to move with M is being restricted to the Z direction.
In the front/back vieports M works like I expected = in both Y and X at the same time.

Hope this explanation makes some more sense?

stooch
11-10-2005, 03:36 PM
aah, hmm i didnt notice that problem (if it is a bug) because i use armatures, but i guess that wont help you in the tutorial...

dOMINUSMess
11-10-2005, 03:41 PM
This is a picture of what actually is an animated gif in the docs:
http://users.skynet.be/dominus/pics/M.jpg (http://users.skynet.be/dominus/pics/M.jpg)

docs -> Tutorials -> Effect & Tool Types -> Flexmotion -> Beginner -> last animated gif after "Guess what? You're done."

It shows points being moved on two axes (Y and Z) at the same time in the Left Viewport, and I only succeed in moving along ONE axis in the Left Viewport when grabbing the "M", wether I've selected the Y or the Z before that or not, and wether I've moved it along Y or Z before that.

I've got the feeling that's not as it should be?
The info on the left viewport next to the Edit Sphere shows also "Mv X: -0.0000" in my messiah, whereas in the picture tou see the "Mv Z: n.nnnn" as it should be.
My guess is this is a bug.
-

DMack
11-10-2005, 05:02 PM
Have you got one of the correct axis highlighted...then tried draging the M again?

That said - this has been raised a few times....if you are in a set palne (top, side etc) it would be logivccal and extremely useful if, when using the M it automatically let you move in that plane (ie in BOTH axis) without any additional steps.

That said, I think the whole edit sphere need a re-look. Sometimes I don't wwant to have my mouse pointer OVER the thing I'm moving....just like LW allows - much faster. The sphere is useful for selecting individual axis to work with and only moving in that axis...but more logic needs to be applied, and having to hit those tiny little edit sphere options when I have the whole screen to play with.......I'm back to thinknig that PMG uses VGA LOL!

isobarxx
11-10-2005, 06:38 PM
It looks like the (M) isn't behaving properly in the non-perspective views when you've got the new coordinate systems turned on.

To get around the issue, try turning off the new coord systems by clicking the Coord Sys button at the bottom right. (On is when the l p w s buttons are showing next to it.)

You can also switch to screen space coords by leaving the new coord systems on and instead clicking the s to switch to screen mode. Whatever's easier.

dOMINUSMess
11-10-2005, 06:47 PM
DMack wrote: Have you got one of the correct axis highlighted...then tried draging the M again? Yes I did.

isobarxx wrote: It looks like the (M) isn't behaving properly in the non-perspective views when you've got the new coordinate systems turned on.

To get around the issue, try turning off the new coord systems by clicking the Coord Sys button at the bottom right. (On is when the l p w s buttons are showing next to it.)

You can also switch to screen space coords by leaving the new coord systems on and instead clicking the s to switch to screen mode. Whatever's easier.
That's it: in screen mode it works!
Now i know where and what to look for for further info on the subject.
Thanks!

Leebre
11-10-2005, 07:06 PM
Lol...

Users - 0
EditSphere - 4,521 (or however many messiah users there are!)

CGTalk Moderation
11-10-2005, 07:06 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.