PDA

View Full Version : normal maps with maya 7 and mental ray


nudnikheadaches
11-10-2005, 12:05 PM
everytime, i try to render with the kileroo shader that i downloaded at http://www.headus.com/au/samples/norm-MR/
it renders perfectly in software renderer,
http://i28.photobucket.com/albums/c227/nudnik/software_render.jpg


but when I render in Mental Ray I get a blown out almost incansence look..
http://i28.photobucket.com/albums/c227/nudnik/mentalray_render.jpg

maybe something is messed up with my render settings?

ive searched around on the forum and tried pixero's js_normalmapper, but it doesnt seem to be compatible with maya 7.

any ideas on what might be happening would be appreciated..


thanks, nudnik

Fifth_miracle
11-10-2005, 07:25 PM
Hi,

What kind of problm are you having with js_normalMapper? I've used it with Maya 6.5 and Maya 7 with no problems. It is currently the best way to render normal maps in Maya. You could use the 2D bump node, and render with the hardware renderer, but who wants that right? :scream: For the headus killeroo normal map you have to adjust the color settings, as the default is setup to work with a Zbrush generated normal map. Do this: change Red To Y, Green To X and Blue To Z. It should render fine.

nudnikheadaches
11-10-2005, 08:16 PM
thanks for the reply fifth.

this is the software render with js_normals,
http://i28.photobucket.com/albums/c227/nudnik/jsnormal_software.jpg
not sure why im getting this incandesent look.. ive tried changing flipping xyz and trying all rgb to xyz combinations.

in addition, if i try to render with js_normalmapper in mental ray, I get this error in the output window..

API 0.0 warn 302018: type conflict: "vector" is type vector, "maya_file" returns type color
API 0.0 error 301031: call to undeclared function "JS_NormalMapper"
API 0.0 error 301036: undefined shader "JS_NormalMapper1"

wonder why you can render with js_normal and I cant..

-nudnik

nudnikheadaches
11-11-2005, 04:23 AM
http://i28.photobucket.com/albums/c227/nudnik/faceted_edge.jpg

started switching the normal camera #'s around and it seemed to work, but mental ray is creating faceted edges as you can see here on the leg.. ive seen this question here before but it was not answered (or maybe it went over my head)
does it have somehting to with maya 7, cause ive seen renders in 6 and even 6.5 with mental ray normal maps and they render with out the hard edges.

thanks, nudnik

Fifth_miracle
11-11-2005, 02:26 PM
Cool, it looks like your starting to get so bump going. For the faceting, have you softened the normals on the geometry, that seems to help.

nudnikheadaches
11-11-2005, 03:43 PM
hey fifth,

yeah I softened the normals and everything.. but had no luck.

i did a plain normal map from zbrush and exported it and mapped it to a sphere and it rendered out fine..

then i thought i would try one of my models.. imported an obj into zbrush, painted my texture, and then exported the map. apply it to my character and again i get it to work but i still get hard faces like the kangaroo.

im wondering if the obj that im exported is bad.. do you have to transfer normals in the obj? ill try when it when i get out of class today..

thanks for the responses,
nudnik

CGTalk Moderation
11-11-2005, 03:43 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.