View Full Version : Material Ids And Seamless Textures

11-18-2002, 07:39 PM
So here's the deal... I'm having my 1st go at texturing a character and so far I'm having lots of fun. That is until I came across this bug? in max (3dsmax5).
I've 2 textures (fig1) , the 1st one is the character's head and the 2nd it's shoulders, chest and back. They both blend seamlessly since they originally were 1 whole image which I then cropped in Photoshop. Next I proceeded to create the materials in max (fig2) I've created a multi/sub-object material, and assigned it to the mesh, which had previously had had assigned the correct material ids in the right areas.
Success! The 2 textures blend beautifully, or so I thought... Here's were the strange part beggins, the textures look fine when close up to the mesh, but as soon as you zoom out, a very nasty seam appears where the textures meet!(fig3)
So my questions are the following,

a.- Has some1 come accross this before?
b.- Is this a bug?
c.- Does any1 know how to get rid of it?
d.- Is this the right approach to texture a character?

I hope some1 out there can help me, thanx in advance


11-18-2002, 07:42 PM

11-18-2002, 07:44 PM

11-18-2002, 07:45 PM

11-19-2002, 08:27 PM
Hmmm.... why are you projecting these images onto planes?? Where is the actual character, or are these renders just for reference to illustrate your problem?

This thing generally happens in any software when you have more than one UV map within the same surface. I have no idea why this happens... it just does :sad:

Why not make them seperate surfaces? Or why not keep it one image in one surface?

11-20-2002, 05:04 AM
"I have no idea why this happens... it just does" - perhaps you could do a little more thinking and less knowing...

a.- yeh i've seen it before,

b.- I dont think its a bug its just how the renderer blends texture pixels together.

c.- I think there may be a few effective work arounds...

try rendering with the filter maps unchecked in the render dialog to see what that does - this will probably not look much good.

You could go to bitmap in the material stack, and try unchecking the tile option under 'coordinates', or experiment with the cropping in the 'bitmap parameters' section

the messiest work around is to duplicate a few rows of pixels on each image and adjust the UVs so that they blend together... then maybe you could just use 1 image?

d.- Is this the right approach to texture a character?

I dont know, that depends on the character a bit


11-20-2002, 03:28 PM
Originally posted by billy
"I have no idea why this happens... it just does" - perhaps you could do a little more thinking and less knowing...

Sarcasm isn't very nice, you know.

By that I meant that I don't actually know the technical reason why the program renders it like that. It's artifact that occurs from multiple projections within the same surface.
I don't claim to know the ins and outs of programming code, so my knowledge is limited to only that.

Xanbob - I actually remember seeing a tutorial for this problem a while back... I'm trying to locate it now...

11-20-2002, 03:50 PM
Here, I found it :)

Layering UV maps without grief (http://www.hpo.net/users/ren/lightwave/tutorials/LW_layereduvmaps.htm)

It's for Lightwave, but hopefully you'll be able to translate it into 3dsmax :)

CGTalk Moderation
01-13-2006, 08:00 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.