PDA

View Full Version : color managment woes


bobtronic
11-06-2005, 04:56 PM
Hi,

I have some problems with PS color managment (using PS 6). I would like to switch off the
color managment but even with the ColorManagment Off preset in the colorsettings my
images have a slight red tone. I can confirm this with PS colorpicker too. So my question is
how to switch off colormanagment? I want my pictures untouched by PS colormanagment.
Btw I even removed the Adobe gamme applet from the autostart, to no avail.

thanks in advance

Bob

spmonahan
11-06-2005, 05:24 PM
Your color issues may be the result of color management being turned off. Color management exists to keep colors as consistent as possible and just about every digital image you create be it a scan, photo, render or painting will default to having some kind of color profile. Turning color management off tells PS to ignore this information sometimes resulting in what you've described in your post.

If you're using Windows, Adobe Gamma exists so you can (more) accurately calibrate your monitor for color reproduction. This is certainly the poor man's color calibration solution, but it's better than nothing.

In my opinion color management is your friend - once you have everything properly configured. I recommend reading this (http://www.computer-darkroom.com/ps8_colour/ps8_1.htm) article. It's for PS CS and it's geared toward photography but I remember it being quite informative about the why's and how's of color management.

halo
11-06-2005, 06:47 PM
you cant switch off CM after PS 4...even if you turn it off, PS still makes some assumptions about your colour space and effectively works with CM on even though it's not actually telling you and worse still it even adjusts your files without telling you, one of which is it will still use your monitor profile...because yours has a red cast it sounds like its bad and you need to do a new one. (jn fact all applications use a monitor profile, BUT PS uses this and an assumption about the files colour space as well)

Its entirely possible to take colour management out of a file, in fact there are plenty of formats that cant support a profile, however PS is now totally CM'd and will make assumptions about colour profiles even if you dont have it switched on

1) it will stull use your monitor profile

2) if you discard, ignore the profile of an opened file or it is lacking one, PS will ASSIGN (NOT CONVERT to) the default a default working RGB profile even if you have it turned off

http://www.gballard.net/psd.html is another extremely useful page for reading.

If you read and learn the VERY IMPORTANT difference between ASSIGN and CONVERT when dealing with profiles you will be able to work out what you need to do with CM on rather than breaking your workflow by really screwing up your colour by thinking your turning CM on when your not...you could discard an assigned profile which will leave your file un CM'd or you can convert to a known profile and then discard, which will make you colours match without a profile.

Two things for certain...

1) your monitor profile is screwed

2) turning things off and breaking the rules is always the last thing you want to do

Hope that helps...bite the bullet and become CM aware, or give up and be lost forever until you do...there isnt any other option.

bobtronic
11-06-2005, 07:29 PM
thanks guys, I got it now. The links were very helpful.

I switched CM on (with all neccessary options) and activated Monitor RGB in the Proof settings. Now my pictures look correct on my monitor.

cheers,
Bob

halo
11-06-2005, 10:49 PM
urgh...ok...there are very VERY VERY good reasons why monitorRGB should NOT be your working rgb space :

WHY? well, if you work in your monitorRGB then ;

a) you are limited to the skewed gamut of your monitorRGB for colours...not as good as a wider RGB space like AdobeRGB

b) unless you know exactly what your doing then its highly likely your file will look different on another calibrated machine from when you left it, especially if you discard the profile when you save or the other person discards it when the open it.

you should pick one of the device independant RGB spaces such as AdobeRGB, AppleRGB, ColourmatchRGB or if your doing web work sRGB and use one as your working space (Adobe RGB is the recommended one for photo work, sRGB for web work). This means that everyone else who you give the file to, who honors your embedded profile will see the file the same as you do on their calibrated monitor. You should save files with profiles as a good practice, it doesnt stop someone arseing them up when they get hold of them, but at least its a pointer in the right direction to someone that knows their stuff.

The common time when you really dont want a profile is for the web where you should CONVERT to sRGB, then save for web and discard...this makes the colours adopt the sRGB space which is the windows default RGB space and makes the file size smaller by not carrying a profile. (sRGB is not the best space, but the most commonly found and common default)

You should switch all your colour management policies to "preserve embedded" and all your mismatches and missing below to "ask when..."

Now, when you open a file without a profile it will ask you to either ;

a) ignore (CM off)
b) assign your default RGB space or
c) assign another space.

What you should do is assign your monitorRGB (c), then convert to one of the 4 device independant spaces mentioned above then work with the file normally. :)

PS you wont ever see the downsides of using monitorRGB as your working RGB space because your working inside monitorRGB, so it will look fine...its one reason people tend to jump on it because it seems to solve their display problems...however if your monitorRGB profile is completely wacked, you also wont ever notice it...but you sure will when your file goes onto someone elses machine!

bobtronic
11-07-2005, 12:53 AM
I use AdobeRGB in CM. I only use Monitor RGB in the Proof setting in the View->Proof Setup menu. As far as I understand it this lets you Soft-Proof/preview you working space on your monitor. So if I want to output to a printer I would choose Working CMYK to preview. Is that right? This is more complicated than I thought. Btw I mainly use PS for texturing 3D models and composing rendered images. Thanks again for your help.

cheers,
Bob

bobtronic
11-07-2005, 01:51 AM
Finally got it right now. It was indeed a broken or incompatible monitorprofile. I installed Windows' Plug&Play monitor driver instead of my IIyama driver and all is fine now. Thanks for the help.

cheers,
Bob

CGTalk Moderation
11-07-2005, 01:51 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.