PDA

View Full Version : sss bump maping issue


maya-3d
10-28-2005, 07:52 PM
hey guy i need a littile help here i made a misss_fast skin shader and every thing worked great but when i applyed a bump map in the bump shader this is what i got .... help me o mighty rendering people :applause:
here are the pics
http://img370.imageshack.us/img370/4296/nobump3ub.jpg (http://imageshack.us)
-----
no bump
--------
http://img370.imageshack.us/img370/6113/withbump1br.jpg (http://imageshack.us)
-------
bump included
thanks ahead :D

PhillipCrond
10-28-2005, 10:56 PM
hey guy i need a littile help here i made a misss_fast skin shader and every thing worked great but when i applyed a bump map in the bump shader this is what i got .... help me o mighty rendering people :applause:

How did you connect the bump to the fast skin shader?

The best method is to create a bump2d node for your texture, then middle-mouse drag from the bump2d node to the bump input on the fast skin's attribute editor page.

erpel
10-28-2005, 11:15 PM
yeah or if you get confused you can apply your bump map to a simple lambert and then drag the bump node in the hypershade to the bump slot in the sss. The thing is I think the sss does not automatically make the bump node if you just load the image file with the arrow thing in the sss.

maya-3d
10-29-2005, 12:01 AM
thank you all it worked great here is the graph for felow cgtalkers with sss probs :deal:
http://img405.imageshack.us/img405/4263/ssswithbum9ey.jpg (http://imageshack.us)

-----
:rolleyes:

MSB
10-29-2005, 05:28 PM
go to your shading group -> mr section -> turn on export with shading engine.this sometime help.


good luck.

floze
10-29-2005, 06:17 PM
go to your shading group -> mr section -> turn on export with shading engine.this sometime help.
Just a small addition: The 'Export with Shading Engine' switch, if turned on, resolves problems with the filtering (crispiness/blurriness) of your bump maps. The bump itself should work without it though.

MSB
10-29-2005, 06:26 PM
Just a small addition: The 'Export with Shading Engine' switch, if turned on, resolves problems with the filtering (crispiness/blurriness) of your bump maps. The bump itself should work without it though.

thx floze, i always wan't to know what that button do I red about it in the sss thread.

cpan
10-29-2005, 08:20 PM
thanx floze, never knew what that switch does :)

btw is there any reason one shouldn't check that "Export with SG"? should we allways set it to on?


thanx again :thumbsup:

TRUST_AND_KILL
03-17-2006, 03:21 PM
It works.. but you loose the alpha..... with pass custom shader on... still loose the alpha.
Anyone knows how to fix tat???

Tx everyone.

TRUST_AND_KILL
03-17-2006, 04:35 PM
Just a small addition: The 'Export with Shading Engine' switch, if turned on, resolves problems with the filtering (crispiness/blurriness) of your bump maps. The bump itself should work without it though.

but you loose alpha of the model... any work araound to fix tat??

floze
03-17-2006, 05:38 PM
but you loose alpha of the model... any work araound to fix tat??
I usually pipe all my stuff through a regular maya surface shader, which provides matte controls.

TRUST_AND_KILL
03-17-2006, 06:34 PM
Good ideia... TX REALY! i will try and will post some feedback.
THE MAN!

leigh
03-18-2006, 11:09 AM
It works.. but you loose the alpha..... with pass custom shader on... still loose the alpha.
Anyone knows how to fix tat???

Tx everyone.


Use a layered shader to fix that. Pipe your SSS shader into the input colour of a layered shadow, and set the flag to Layered Texture. Then change the transparency slider to black, and pipe the shading group node of the layered texture into your light map. This fixes this problem.

CGTalk Moderation
03-18-2006, 11:09 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.