PDA

View Full Version : Texture crawling/jitter, ellipticFilter issue


Arcon
10-23-2005, 01:18 AM
I've been experimenting with the ellipticFilter.mi utility. I've found the default settings provide a slightly crisper texture which is good (not quite as sharp as Maya Software, but still passable). Even at -1 1 global samples it also does an excellent job eliminating moire patterns on repetitive textures that are far from the camera (eg. checkerboard).

PROBLEM: As far as file-texture jitter/crawling goes, its actually slightly worse than just regular quadratic filtering (or is that pyrymad in MR?). Is there a setting in the elliptic filter that will actually help get rid of texture jitter (without just blurring it which will basically ruin the object's composition with the rest of the shot). Increasing global samples doesn't really help this much.

By far the best results for file textures I can get only with Maya Software renderer, and its much faster. However the moire patterns with the Software renderer are very bad. Obviously I would rather use MR, but can't find a setting to get rid of texture crawl.

Any ideas would be welcome :)

EDIT: Oh I forgot to add, there are no radiosity effects in the tests ;) And one more question, is the per-object MR sampling working in Maya 7 now? this feature is broken in 6.5 :rolleyes:

Arcon
10-23-2005, 04:56 AM
i got an improvment in texture jitter results by dropping RGBA contrast values from .05 to .025, there was a 20% performance hit on render time :( still its a better method than using 0 2 sampling instead which has the same performance hit but didn't help as much.

at least now textures look as good as the software renderer :bounce:

CGTalk Moderation
10-23-2005, 04:56 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.