PDA

View Full Version : Here we go again - more Spline Patch questions...


MiWi Graphics
08-14-2005, 09:01 AM
Hey Guys,

Did another spline tutorial - a spoon this time. I'm attaching two lwo's this time. First one is the spline cage and the second one is the patched version. Something went wrong with the spoon handle end - think I split the point. Anyway, in regards to the two ends - should I weld those points before patching? Or patch and then weld all of the point pairs? Thank you in advance - as usual!

Later - Mike

::keith::
08-14-2005, 04:17 PM
OK here's my 2 cents. You should have fixed the spline problems at each of the ends before patching although it's also a simple fix to do on the polys afterwards.

On the version that you've patched, the splines either side of the z axis should be smoothed together (ctrl+s) so you avoid the sharp crease down the middle of the spoon.

You also seem to have patched at a very high mesh density. You should probably use much fewer polys and then hit tab to convert those to a SDS.

On layer 6 you have a bunch of 2 point polys. Delete 'em.

Finally, for such a simple object, spline patching is overkill. Since it's a tutorial though it's all good I guess.
Good luck,

Keith

MiWi Graphics
08-14-2005, 04:48 PM
But how do I fix the ends? I wish these tutorials were a little more in depth! I understand the process of drawing the splines, creating the closed curves, and then splitting them to create the patches. But what is getting me is when you have to account for things like the ends on this spoon and on that knife that I posted about earlier. Thanks for the tips!


Later - Mike

PSR
08-14-2005, 08:02 PM
One of the main advantages of using Splines is to get good polygon flow on your mesh. Experiment with the Knots and Lengths options, in the Make Spline Patch dialogue box.
Just make a patch, see the effect, Ctrl-Z to undo and then try it again with the other option.
Notice the effect it has on the flow of polygons.

Here's an example of a way to deal with the ends:

MiWi Graphics
08-16-2005, 03:33 AM
Hey guys - well, I finally nailed this down. I got a lot of really good help from this forum, from SpinQuad, and also from the Newtek forums. Attached is the current .lwo and .jpg. Thank you for all of the help guys - I'm on my way ;-)

Later - Mike

CGTalk Moderation
08-16-2005, 03:33 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.