PDA

View Full Version : Brazil caustics, 3dsmax self-illumination output.


Ian Jones
10-28-2002, 07:11 AM
Hi there.

I'm just new to 3dsmax and Brazil, I'm trying to achieve more control out of the colour of my caustics / radiosity when I'm using a max material with self-illumination and diffuse set to an 'output' map with rgb level and output amount set to 2. I can adjust the colour in the diffuse slot and achieve some washed out colour caustics and radiosity... but what I want is more control over the colour of the object emmiting, and the saturation and intensity of its colour.

What methods do you guys use?

Ian Jones
10-28-2002, 07:19 AM
heh.. disregard the caustics bit... I don't understand my terminology yet. Anyone have a good reference for cg terminology? Besides the tutorial I did was wrong, I didn't need caustics turned on to get an object to cast light.

Its just GI that is lighting the scene....I think... :)

It does however make a difference with refracted and reflected rays, which as I understand it is what caustics is all about. Light being bent, usually by a curved surface, and concentrated onto a receiving object. Is that right?

Any info would be much appreciated.

visualboo
10-28-2002, 07:50 AM
If you want the object to actually become a light source, just crank up the self-illum. I think your talking about the light that's being bounced off an object onto say a floor though. correct?

And I'm still a little confused about your question. ---->

"but what I want is more control over the colour of the object emmiting"

textures? Press the M key and tweak away. If that was way off let me know.

Ian Jones
10-28-2002, 08:00 AM
sorry... :)

I have it working, but you'll see what I mean when you view the attached pic. Ignore the filename, I'm more interested in controlling the radiosity and GI than the caustics.

Basically I want to make the emmiting objects into a colour, and have them cast that colour, with control over the saturation fo that colour and intensity...because atm it is washed out and the light sources are just plain white.

Khepri
10-28-2002, 06:36 PM
ok, there are more than 1 way to go here, but the most simple one is this:

standard max material, 100% self illumination, in the diffuse channel put an outputmap(and increase the rgb intensity) and in the map-slot of that output map you can put any bitmap for coloring, or a "rgb tint" /"rgb ramp"/etc map for colour.

:) hopes this helps

visualboo
10-28-2002, 07:23 PM
yup, that works. Try using a SolidColor map in the output map channel.

If you don't have it, it's on the blur site. www.blur.com

visualboo
10-28-2002, 07:33 PM
also, you can try setting the self illum amount to 25 (or whatever) and crank up the output amount in the output map in the diffuse channel (to compinsate for the self-illum). That way you can still get shadows on the light source object. Well sorta ;) but you can get some cool results with it.

Ian Jones
10-29-2002, 07:05 AM
Thanks guys... it worked.

I added an additional bitmap to the map slot of the diffuse output map. It works a charm. This is only a test scence, it does animate too... what I am perplexed about is the two white blurry marks on the upper part of the glass orb. I can't figure out how they are getting there, the only lightsources in the scene are the sphere and the block. They cast blue, yet the marks are white. They do now appear to be a reflection of anything, and furthermore they do not move even when things are animated...

The glass is brazil glass material.

any ideas? perhaps a known bug?

Ian Jones
10-29-2002, 07:31 AM
Here's the result btw. (I forgot and couldn't edit it into the last post)

Ian Jones
10-29-2002, 07:35 AM
Gah, it was the default max light.... hehehe. I hate being a newb.

CGTalk Moderation
01-13-2006, 09:01 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.