PDA

View Full Version : Bezier curve handles lock along axis?


vexir
07-08-2005, 03:51 AM
I'm trying to drag the handles of a bezier vertex and for some reason the handle sometimes locks along a certain axis, for instance, it will only move sideways, but the handle will not move up or down or diagonal or anything.

Does anyone know how to disable this? It's really really annoying and I don't see the point of such a stupid auto-locking thingy.

mgreenway
07-08-2005, 03:54 AM
vexir,
I don't know why but it happens to me to.
Puzzled

Kreez
07-08-2005, 04:18 AM
I would like to know as well, this really annoys me.

vexir
07-08-2005, 04:35 AM
I think I just got around it, I took the Select and Move tool, grabbed the corner of the transparent-yellow square (in between the move axes) and moved it around a bit, and then I was able to drag the handle wherever I wanted.

Go figure? MAX is wierd.

-Vormav-
07-08-2005, 06:15 AM
This happens all the time with bezier handles, because the handles are usually very close to the move gizmo. If you click on one of the axis directions on the gizmo, max locks movement to that axis (similarly, clicking on the yellow box opens the movement up to all directions).
Just hit 'x' to hide the move gizmo while you're moving the handles around (it's good to hide the gizmo when you're trying to snap to the grid, too). Or you can just change the gizmo size a bit until it gets clear of your handles.
It would be a lot better if you could just select handles the same way as vertices (as you can with the handles of patch surfaces)...

vexir
07-08-2005, 08:38 AM
Ah I see, thanks a lot :) Cheers!

mynewcat
07-08-2005, 08:41 AM
It would be a lot better if you could just select handles the same way as vertices (as you can with the handles of patch surfaces)...

You can do that in Max 7 can't you?

mentok
07-08-2005, 10:47 AM
this always annoyed me...my quick way of gettin around it is to drag the yellow box a littlein both the x and y and then release and right click at the same time ..which cancels your movement but seems to give back x and y movement to the bezier handle.....one of maxs many quirky features!

mgreenway
07-08-2005, 10:21 PM
Thanks Vormav!

emptyvoxel
07-08-2005, 10:42 PM
this always annoyed me...my quick way of gettin around it is to drag the yellow box a littlein both the x and y and then release and right click at the same time ..which cancels your movement but seems to give back x and y movement to the bezier handle.....one of maxs many quirky features!

By default, max will continue constraining to an axis if you use your axis gizmo to drag anything.

Hmm... reading that over again it doesn't seem very clear. From the help: "When you position the mouse over any axis, it turns yellow to indicate that itís active. Similarly, position the mouse over one of the plane handles, and both associated axes turn yellow. You can now drag the selection along the indicated axis or axes. Doing so changes the Axis Constraints toolbar "Restrict to ..." setting (using_the_axis_constraints.html)."
There are a few things you can do to remedy this situation:

1) Right-click between the buttons on your main toolbar and check 'axis constraints,' which will bring up your axis constraints toolbar. You can drag it up next to your main toolbar to easily see which axis you're constrained to, if your screen resolution is high enough of course.
2) By default, the axis constraints hotkeys are f5=x f6=y f7=z, and f8 is a smart button which will toggle between xy, yz, and zx constraints. Very useful!
3) You can tell max to not save the axis constraints if you use the gizmo. Just edit your 3dsmax.ini file, and under the [performance] category, change

TransformGizmoRestoreAxis=0

to

TransformGizmoRestoreAxis=1

That's the first thing I do when installing a new version of max. There's got to be a way to do this through the menus, but I've never found it.

Good luck!
~T

kabojnk
07-09-2005, 01:17 AM
What I do to get around the problem is to highlight the yellow square (meaning having control over both X and Y axes) and then hitting the 'x' key to turn off the axis. Then I can edit the curves without the axis getting in the way. When I'm done, or when I've modified it enough for it not to interfere with the axis gizmo, I hit 'x' again to turn it back on.

Apparently when you turn of the axis gizmo while you leave it highlighted on both X and Y, you can still edit vertices/spline handles/whatever on those axes. I don't know if discreet purposefully made the interface work like that, but it sure does help.

CGTalk Moderation
07-09-2005, 01:17 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.