PDA

View Full Version : Everyone's Favorite... MR and SubDiv


Nunyas
06-28-2005, 01:57 AM
Hi all,

I'm new here. I've looked through the numerous threads regarding MR and SubDiv rendering under Maya. The problem that I'm having doesn't seem to have been answered though. At first i couldn't get SubDivs to render, but a quick search in the help file solved that issue for me. But my current problem is that MR is not rendering FullCrease edges properly. I'll post a couple of renders shortly. Maya software renders seem to render the shapes as i see them in editing, but MR severely rounds the edges and corners...

So far, the only thing I've be able to figure out is to convert back to Poly (I model in Poly then convert to SubDiv) in order to get the correct shape. However, the edges on the modeled pieces are too sharp, and I'd like to avoid selecting every single "boarder" vertex/edge on my model to smooth/round it if possible.

In short, I like the rolled straight edges that MR + SubDiv is giving me, but the overly rounded corners are driving me mad. So, is having to hand round the same edges on the poly model...

So, anyone have any ideas or suggestions?

Thanks :)

Nunyas
06-28-2005, 06:15 AM
oh ... it finally made it up... i'll post those comparison renders for you folks now:

SubDiv model rendered with Mental Ray:
http://nunyas.dyndns.org/%7Emax/images/MR_SubDiv.jpg

And now the same SubDiv model rendered with Maya Software:
http://nunyas.dyndns.org/%7Emax/images/MS_SubDiv.jpg

I want the rolled edges from the Mental Ray render, but corners that more closely resembles the corners from the Maya Software render... Is there an easy way to do that?

Thanks again :)

Nunyas
06-28-2005, 05:04 PM
well, there seems to be a delay in my previous post (#2) due to the nature of the system here, which I have to say is a good idea. :) Since my posting of my SubDiv + MR rendering issues I've discovered some ... flaws in my modeling technique. I may have figured out how make things right on my own, but only time will tell. :p

In short my problem isn't necesarily a rendering issue, I think it may have to do with 'clearly' defining the edges while modeling.

At any rate, I'm sure my second post will make it through sometime today. At which time, someone might be able to make some suggestions, or tell me whether my thoughts are right or wrong. :)

butCherHeLL
06-29-2005, 02:52 AM
may be you need to read one of thishttp://kursatturkay.port5.com/maya/tutorials/subdiv_render_quality/subdiv_render_quality.htm

hm?

Nunyas
06-29-2005, 07:30 AM
hmmmm... i'll give that a whirl and see how it turns out. I've already gone back and 'tweaked' the heck out of my low poly version of the model with the intention of keeping it in poly. So far, the parts that I've done are turning out great with poly smooth, but the conversion to SubDiv with the current model is less than spectacular. I'll play with it some anyways to see if i can make the subdiv model look any better.

Thanks for the tips :)

CGTalk Moderation
06-29-2005, 07:30 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.