PDA

View Full Version : Procedural texture buzzing


plug3
10-03-2002, 02:20 AM
Hi,

I tried to render an anim of an object with a rock texture node but the result is flickering like crazy. I tried cranking up the AA settings but it still buzzing.
Could I use a renderMap to generate a bitmap of that procedural texture and would that help?
Also I used a spatial texture projection, is that an issue?

If you know any tuts about renderMaps that'd be welcome.

As you tell I'm kind of a newB to XSI.

Thanks in advance.

Atyss
10-03-2002, 04:46 AM
Is the texture projection frozen? If not, that might be the cause of your problem.


Hope this helps
Salutations - Cheers
Bernard Lebel

plug3
10-06-2002, 05:37 AM
Thanks for your help.

Yes the texture is frozen. (I did search the forum prior to posting and saw a lot of posts from you !)
I gave up procedural textures and spatial projection and went with a straight bitmap and planar projection ( and froze it !)
But same buzzing.
Then I found out about elliptical filtering and that did reduce the flickering, it is still there but smaller.
The thing is that it is very tedious to test the different filtering settings and the docs are not very helpful as far as describing those settings (Maximum Pixels for Minimum Radius: Defines the maximum number of texture pixels for the minor radius of the ellipse :hmm: )

Well, good news: I was doing a test while typing this and the buzzing is almost entirely gone.

Atyss
10-06-2002, 03:36 PM
Ok so I guess the problem has to do more with rendering than textures themselves.

The anti-aliasing you should try are
Sampling min -1
Sampling max 2
Treshold: 0.05 (all 4 values)
Filtering: Gaussian
Size X and Y: 3

You can also use a Mitchell and Lanczos filtering with sizes of 4/4.


Hope this helps
Salutations - Cheers
Bernard Lebel

plug3
10-07-2002, 02:45 AM
:thumbsup:

The AA settings with the Mitchell filter did the trick.
No more buzzing and the render time is not bad.

Did you get those settings by trial and error?

Thanks again.

Atyss
10-07-2002, 03:00 AM
Glad I could help!

Actually, I got these settings while I was in school, my teacher gave them. They work in most situations.


Cheers
Bernard

CGTalk Moderation
01-13-2006, 06:00 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.