PDA

View Full Version : rotating camera view and other stuff...


Kananga
09-27-2002, 09:42 AM
Hi
three questions....

1) How do you set the camera view so the view rotates around the selected vertices (for example).Thats the equivilent of arc-rotate subobject in Max. Is this possible?

2) Is it possible to hide the lights but still have them light the model. When I hide the selected lights, everything goes dark. I want them to light stuff but not be displayed if you get my meaning.

3) I want to get in close to the model ( to model a finger nail for example) but the model disapears when I zoom in too far. I cant set the near clipping plane any closer. What gives?

Hope someone can help me with these questions!:surprised

vmpre
09-27-2002, 11:50 AM
1) When you have the vertices/edges/polygons/objects/whatever selected, hit the "F" key to frame the selceted thingy. This will center the obejct in the viewport you are working in. If that is the camera view, when you rotate around the object it will rotate around whatever you framed your selection on. Hold Shift + F will frame the selection in ALL viewports.

2)Select the light, from the Explorer window open the light, open the property called "Visibility", make sure View Visibility is unchecked. This will not display the object in the viewport and make sure that Render Visibility is CHECKED, this will make the object visible at rendertime, and in the case of lights, the light will light your scene with out displaying in the viewport.

I suggest you look into Layers in XSI, I like to put all my lights into a layer then I can in one easy step hide/unhide, Render Visible/Invisible, and Selectable/Unselectable.

3) take a look under camera properties, there should be settings for clipping planes.

Lastly, not to be a jerk, but really, read the manual. All these answers are in there.

HTH
Vmpre

Kananga
09-27-2002, 11:54 AM
nice tip about layers there. Thanks.

And Im just flicking through the manuals now...your right, its all there.:cool:

Kananga
09-29-2002, 04:36 AM
um, actually, and god knows the manuals arent much help with this, I've done exactly as youve suggested and my scene still goes dark when the lights are hidden. Damned annoying:D

View Visibility is unchecked

Visibility is CHECKED

Scene goes dark

I realy just wanted viewport lighting with the lights not displayed. Should be simple......isnt:surprised

Thanks for your time and help anyway

vmpre
09-29-2002, 03:31 PM
Thats strange.

I just did the same thing here and it worked.

So, you opened the Visibility Property Page (ppg) for the light and have View Visibility unchecked and Render Visibility checked and your scene is still dark?

Um, yeah that should work. Very strange.

Well, the next thing I would say would be to put you lights into a light layer and from the Layer control (6 on your keyboard) uncheck view. That should also hide the lights but still make them visible.

Very strange. I have not had a problem like that before.

Also try killing off that light and bring in a new one and try again. Maybe something got fouled up.

HTH
Vmpre

Oh, one more thing...could by any chance, the normals of your object be flipped? Backfacing polygons in XSI will appear black. So if the normals are pointing away from your light, the polygons would be black.

Kananga
09-29-2002, 11:48 PM
No, I dont think its the normals, the whole scene goes dark. I've just put the lights into a layer as you suggested, and made them unselectable, which is ok for now.

But yeah I might try resetting my light rig, start from scratch.

Funny, I had a layer plugin for Max which I used all the time. Not sure why I took so long to make use of XSI's, but its cool. Makes the package a whole lot nicer to use:thumbsup:

CGTalk Moderation
01-13-2006, 06:00 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.