PDA

View Full Version : Volumic light shadow artifacts


Chris-TC
03-29-2005, 01:01 PM
Hi,

I'm working on a scene and introduced a volumic light. No big deal I thought until I saw the massive artifacts it produced.
I thought it might have to do with GI, some of the materials, the light properties or anything, but I stripped this scene down to almost zero and the artifacts are still there.
I even exchanged the light with a new one, but the effect is the same.

Here's an image. The artifacts were worse on the full scene but they're still clearly visible.
http://www.adventurefan.de/birdseed/volume.jpg

The scene is now as basic as it gets. Only standard materials, no fancy rendering options, no complex geometry.

Does anybody have an idea what might be causing this?

In case you wanna have a look, here's the barebones scene I took the render region from:
Scene (http://www.adventurefan.de/birdseed/artifacts.scn)

-Chris

P.S.: The bars are just standard cylinders with 2 V and 24 U divisions.

Strang
03-29-2005, 01:20 PM
did you check your render options?

your AA settings?
your filter and its size?
Threshold?

Atyss
03-29-2005, 02:48 PM
Increase the volumic map size.


Cheers
Bernard

Chris-TC
03-29-2005, 08:29 PM
Hi,

I just tried increasing the volumic map size to 2048, but it didn't help.
My AA settings are -1, 2 with a threshold of 0.15, Lanczos filter at 3x3.
I changed them a couple times, but the artifacts didn't change at all, so it seems to have nothing to do with AA.

I also moved the light around cause I thought it might have something to do with the angle at which the light is hitting the bars. But even when I center the light behind and slightly above the bars, I'm getting these results.

http://www.adventurefan.de/birdseed/volume2.jpg

MJV
03-29-2005, 09:26 PM
Looks pretty messed up. I definitely don't think lighting effects is XSI's strong suit.

Strang
03-30-2005, 02:45 AM
Looks pretty messed up. I definitely don't think lighting effects is XSI's strong suit.

would be nice to know if this is MR or XSI thats causing this?

Chris-TC
03-31-2005, 10:47 AM
Hi,

Both XSI and mental ray are fantastic pieces of software and I couldn't believe that there's nothing to do about the artifacts. So I played around some more and I found the solution.

Actually I'm surprised nobody could help me on that because you get very similar results if you start a new scene and create a standard floor grid, a standard cube and a standard volumic spotlight.

The Scene_Root has a global property called Volumic Properties. If you open up the PPG, you can set what is called the sampling step size. By decreasing it I was able to get rid of all the artifacts. I had to set it really low (well below 0.1) and now everything's looking just fine.

Cheers,
Chris

3dtutorial
03-31-2005, 11:35 AM
Hi Chris_TC,

Good tip -- thanks for posting your solution.

Glad to learn that you were able to get this sorted out -- I'm sure this will help some other people as well.

Cheers,

Joe

Chris-TC
03-31-2005, 02:07 PM
Thanks, yeah I hate nothing more than reading about a problem in a forum with the poster telling us at the end that "I figured it out, thanks anyway" and not explaining how the problem was solved.

Cheers,
Chris

Strang
03-31-2005, 03:50 PM
yes thanks.

making proper use of public forums

Saku-Pekonmaki
04-03-2005, 09:56 PM
Chris TC

I do not know alot about xsi as a 3d tool, where as I use 3dmax.

my guess is that this occurs due to the shadow settings.

In 3d studio max I would be able to simulate this with basic shadows, but changing the shadows to a different type of shadow should eliminate these artifacts.
try using Raytraced shadows ?!

by the way Im intrested how your BMW went? (2003 bmw 520 e39)
excellent rims if you could share your making of them :)

CGTalk Moderation
04-03-2005, 09:56 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.